Page not found: Facebook says The 'og:type' property is required, but not present.

For the past two days, when our blog post is shared on FB, it shares the photo with the descriptor: Page not found. If I click through the photo, I find the page, so the link works but won't display the post title properly.

When I input my post title http://lifeforleaders.org/practicing-the-presence-of-god-at-work-part-1/ into FB's open graph debugger, I was found this:

Open Graph Object Debugger
Input URL
When and how we last scraped the URL
Time Scraped 12 hours ago
Response Code 404
Fetched URL http://lifeforleaders.org/practicing-the-presence-of-god-at-work-part-1/
Canonical URL http://lifeforleaders.org/practicing-the-presence-of-god-at-work-part-1/ (2 likes, shares and comments More Info )

Warning
Critical Errors That Must Be Fixed
Bad Response Code URL returned a bad HTTP response code.
Warning
Errors That Must Be Fixed
Missing Required Property The 'og:type' property is required, but not present.

I'll send a screenshot if you'd find it helpful.

Hoping someone tell me how to fix this!

Best,

Catherine

  • Milan

    Hi @Catherine Beaton,

    I hope you are having an awesome day.. ( Except this issue.. :slight_smile: )

    I've shared your page on my Facebook wall and everything is working fine. Page shared with proper title and content, When I clicked on page link it also get me back to shared page.

    If problem is still there please do attache screenshots of problem and also enable support staff login so I can check in more depth.

    Warmest Regards,
    Milan..

  • Catherine Beaton

    Thanks, Milan, for following up on this.
    Facebook is working again as it should, but the two posts on the Life for Leaders FB page still display with "Page not Found." [See screenshots.] I've tried sharing both from the Life for Leaders FB page on my FB page AND sharing from the post itself, and I get the same "Page not Found" message. It's just on those two posts for some reason. Is it possible (or fairly simple) to fix this? And, is there a way to prevent this from happening in the future?

    So, I hope you're having a great day! I'm conceding to this week being full of funky glitches. You will notice that I now have 4 share bars on every post page. :wink: I had this occur a few weeks ago and it was fixed by Michael (I think), but it's back and I need to hunt down the fix he told me about. If you can help with the share bar thing, please do. Otherwise, I can pursue my old ticket and replicate it. Let me know?

    I don't know if this is relevant, but I was trying to insert an email list sign-up button on my home page. My attempt was unsuccessful and I will open another ticket for that. But I wonder if I inadvertently messed up the buttons (none of them display as they once did before I tried to do this).

    Well I've had a long day. I think I'll stop here before something else goes awry! :wink:

    Thanks very much for your help!!

    Catherine

  • Milan

    Hi @Catherine Beaton,

    I am glad that everything working as expected. :slight_smile:

    Right now I don't think there is any solution out there for fixing already shared post except re-sharing those posts again.

    For share bar thing I tested @Michael Bissett solution and it is working fine. I think this is very good solution for you as you only need to add some custom css code. If share bar is re-showing again I think code you've added as custom css must be gone. Please try to add it once again. :slight_smile:

    I was trying to insert an email list sign-up button on my home page. My attempt was unsuccessful

    Dear @Catherine Beaton this question is off topic so I suggest you to create new thread for this. :slight_smile:

    So I think that's it. If I forgot to include something or you need more help with something else don't hesitate to ask. I would be happy if I can help you with something. :slight_smile:

    Enjoy Wpmudev..

    Warmest Regards,
    Milan..

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.