Page not found message after subscription paid

Hello, I did a live subscription on pro sites. After a person has paid he receives this message:

"Your PayPal subscription was successful! You should be receiving an email receipt shortly.

Thank you for becoming a premium label.
You may access your account here: Login"

When a person clicks on this Login hyperlink it gives a page not found error and the user is left not knowing where to go.

  • Atlanta

    I tried it several ways

    1.

    In your PayPal settings under Profile-->My Selling Tools-->Website Preferences-->Update
    Auto return is on? NO
    Payment Data Transfer is on? NO
    In addition, in your PayPal settings under Profile-->My Selling Tools-->Instant payment notifications-->Update YES

    After the purchase I was directed back to my site and received this message..You may access your account here: Login BUT the login link led to a page not found error.
    "Your PayPal subscription was successful! You should be receiving an email receipt shortly.
    Thank you for becoming a premium label.
    You may access your account here: Login"

    2. After your response I tried
    In your PayPal settings under Profile-->My Selling Tools-->Website Preferences-->Update
    Auto return is on? YES
    Payment Data Transfer is on? YES
    In addition, in your PayPal settings under Profile-->My Selling Tools-->Instant payment notifications-->Update
    Instant Payment Notifications is on? YES
    Version of WordPress? 3.3.1
    Version of Pro Sites? Version 3.0.9

    In PayPal settings under Profile-->My Selling Tools-->Website Preferences-->Auto Return URL I entered my http://domain.com/wp-admin to take people to the admin panel after check-out but it gave a page not found error message. The url bar read http://domain.com/premium-wholesale/\"http:disappointed:domain.com/wp-login\"

  • Atlanta

    Oh I see, it is redundant info. The return page is already built in to the pro sites script so if I enter a return url it shows twice in the address bar and cannot pull up a page.
    So the correct setting is
    In your PayPal settings under Profile-->My Selling Tools-->Website Preferences-->Update
    Auto return is on? NO
    Payment Data Transfer is on? NO
    In addition, in your PayPal settings under Profile-->My Selling Tools-->Instant payment notifications-->Update YES

    Correct?

  • aecnu

    Greetings Atlanta,

    In your PayPal settings under Profile-->My Selling Tools-->Website Preferences-->Update
    Auto return is on? NO
    Payment Data Transfer is on? NO
    In addition, in your PayPal settings under Profile-->My Selling Tools-->Instant payment notifications-->Update YES

    The correct settings would be:
    Auto return is on? YES
    Payment Data Transfer is on? YES
    In addition, in your PayPal settings under Profile-->My Selling Tools-->Instant payment notifications--> enabled with your web site url in the applicable place.

    Please let us know if this does not resolve your problem by reopening this ticket below marking it as not resolved. Also please indicate if there are any new symptoms or errors.

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.