Page overlay with slide in

I am using my subscriber Hustle Pro on another of my sites, and the slide in appears fine and does not produce a transparency overlay on the rest of the page. This is the expected and prescribed behavior.

I am using basically the same settings, using Free version on my work site for a single slide in; however, when it appears, it causes a full page overlay (darken the page behind it) like a pop up normally does. This is unwanted behavior for a slide in and I can't find any setting to remove the overlay when the slide-in appears.
We are using the Uncode theme and I cannot allow remote access unfortunately.
Am I missing a setting, or is this normal behavior for the free version?

    Nithin

    Hi Kliqks,

    Hope you are doing good today.

    Developers are working on it, at the moment I don't have an exact ETA on when a patch regarding this fix will be issued, will keep you posted once we have a fix ready for this bug. As a workaround, please try the following CSS, and check whether it works fine:

    body:not(.wp-admin) .wph-modal--mask {
    	display: none;
    }
    
    html.no-scroll body {
    	overflow: scroll !important;
    }

    You can add the above CSS code, using Custom CSS box(if your theme offers), or either using a Child theme, or a using the default Customizer under Appearance > Customize > Additional CSS.

    If the CSS doesn't work, please point us to the site where it's enabled, so that we could give a closer look. Please let us know how that goes, have a nice day.

    Best Regards,
    Nithin

      Kliqks

      I gave it a try, here are the results:

      A short primer - We use Uncode theme with lots of animated CSS for elements to drop into the page.

      Without the above CSS code, the Custom Content Slide-in works fine, but adds the overlay as the pop-up would; however, the page elements also continue to scroll and animate even behind the slide-in overlay.

      With the code above added to the themes overall CSS area, the Slide-in does indeed work and the overlay is gone; however, the page scrolls, but the other animated elements fail to appear until the Slide-in is either dismissed or times out and terminates on it's own via the settings. This also causes a page blip/jump when the elements all appear at once.

      At this time, I do not have the slider activated on our live site.

      Thanks!

    Rupok

    Hi Kliqks,

    So sorry to hear the inconveniences. The code Nithin provided above was based on generic Hustle class name. So it should work fine unless anything from your site is overriding this.

    However, we could provide you working custom CSS code if we could inspect your site elements live. Is it possible to add that slide-in on any specific page of your site and provide us the link to that page so we can inspect this there and provide you working custom CSS code to fix this?

    If you want to send us the URL secretly, can you please send me a message with the URL through our secure contact form here: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: "Attn: Rupok"
    - Your Site URL where we can see this slide in issue in action
    - Link back to this thread for reference
    - Any other relevant URLs

    The subject line ensure that it gets assigned to me.

    We will jump in after you confirm. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok