page speed not good.i get some error always

how to fix this issue?
gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

  • Denitsa

    Hello irfan,
    I hope you are having an amazing day and thanks for asking!

    The message suggests that the "mod_deflate" module may not be enabled, will you check with your host if you indeed have the mod_deflate on?

    If that's a positive, will you check for the following:
    1) If you have any server-side caching solution (like Varnish) please purge its caches;
    2) Check via FTP whether you have this line in your php.ini
    zlib.output_compression = On

    In case it's set to "off" you will want to change it to "on" and restart Apache.

    You might also want to write the necessary rules to your .htaccess file manually via FTP as suggested by Hummingbird on Hummingbird -> GZIP Compression.

    Let me know how it goes!

    Warm regards,
    Denitsa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.