Page will not become unprotected when all memberships are removed from access

Hello I have a custom post which is a paid event

https://londonrealacademy.com/events/create-a-life-that-means-something-an-evening-with-phil-mckernan/

And I have tried making it available to even non registered visitors by removing all memberships BUT the page then becomes blocked to everyone as if it was still protected but had no specific membership.

How do I clear that up?

  • Bojan Radonic
    • Head of Support

    Hey there @Dre, hope you're well today!

    I've tested this on my end first to see if I can recreate the issue and it appears that this is a bug since removing protection is not properly saved. Once you remove protection from custom post type then click on some other link in the admin and come back you'll see that it is still shown as protected.

    I'll report this to our developer so he can take a look. Thank you for reporting this :slight_smile:

    Best regards,
    Bojan

  • Bojan Radonic
    • Head of Support

    Hey again @Dre,

    Just wanted you to know that we've released update for the plugin which should fix the issue with removing protection that is not properly saved.

    Please note that the fix will only solve the issue for future changes, not for already protected pages so for current ones where you had this issue you'll have to protect + unprotect the affected pages again to clean the invalid "protection flag" from the database.

    Best regards,
    Bojan

  • Dre
    • The Incredible Code Injector

    OK got it back by manually deleting the plug in, loading the old version and getting a Rackspace engineer to reset the caching system.

    This is what they said

    As discussed on the phone, your website https://londonrealacademy.com/ was not loading correctly because Varnish on cloud-server-01 had stopped. Below you can see that this morning your server was running out of memory this morning due to php5-fpm processes growing too large. This in turn would have forced varnish to shut down, though this isn't mentioned in the logs. The configuration allows each process to use 320M of memory, and for 100 processes to be created. This means that php5-fpm will try to use 32G of memory, when your server only has 4G. You should reduce the memory_limit in /etc/php5/fpm/php.ini to a better value.

  • Bojan Radonic
    • Head of Support

    Hey there @Dre,

    Glad to hear you managed to get your site back online and thanks for additional information. I'll pass this on to our developer for some feedback and let you know as soon as I have any information.

    On the side note if you're not using any caching plugins you should consider doing so, a good example would be https://wordpress.org/plugins/w3-total-cache/.

    You can find a tutorial how to setup it here: http://www.wpexplorer.com/wordpress-w3-total-cache/.

    Best regards,
    Bojan

  • Bojan Radonic
    • Head of Support

    Hey again @Dre,

    A quick follow up on this one. I've discussed this with our developer and he told me that this could be related to one of the features that has been added to the plugin and that he will disable it in the next update.

    Hopefully this will fix the issue :slight_smile:

    Best regards,
    Bojan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.