Pages not Publishing (New or Editing Existing)

On 2 of my WP networks (on the same hosting reseller), when trying to publish a new page in WP I get sent to the ‘Posts’ page and my page is added as a draft.

When trying to update an existing page I get sent to my home page.

I think it could be memory problems but I’m not aware how to fix.

I have an extra issue of not being able to contact my server admin right now either :slight_frown: but I have reseller and account access via cPanel to other areas.

I haven’t made any recent updates of plugins, wp or themes. So it’s not isolated to a specific plugin.

If anyone could shed some light I’d appreciate it.

thanks

Paul

  • aecnu
    • WP Unicorn

    Greetings Paul,

    This is indeed a strange issue that I have never heard of or experienced before.

    I think it could be memory problems but I'm not aware how to fix.

    Lets find out about the possibility of it being a memory problem and see what memory you do have.

    I have attached a file that you would want to download, extract, and then upload the phpinfo.php file to the root of your hosting account.

    Next is to call it up in your browser: http://yourdomain.com/phpinfo.com

    You should then come to a screen similar to this one here.

    Then locate memory_limit and max_execution_time and let us know what the values are.

    Of course this indicates how much memory is available, but what about how much is being used?

    The WP-Memory-Usage plugin will give you some idea what the memory usage is, of course this is when the site is idle.

    I have included a screen shot of memory usage of our test production server.

    Please advise.

    Cheers, Joe

  • member1
    • The Incredible Code Injector

    Update:

    I’ve run a phpinfo.php test and it shows memory limit 48mb

    I created a php.ini file and added memory_limit = 64MB

    The phpinfo display updated to the new figure, but when I went to test editing an existing page I received a fatal memory error.

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 19456 bytes) in /home/xxxxx/public_html/wp-includes/load.php on line 413

    I tested the php.ini file with the following values:

    128mb & 256mb but received the same memory error.

    When I removed the php.ini file the error was gone, but I’m back where I begun.

    I’ve begun deleting some unused plugins, but I don’t thinkn this is the problem as I have the same problem on another site on the same hosting with only a few plugins

    Thanks for any tips.

    Cheers

    Paul

  • aecnu
    • WP Unicorn

    Greetings Paul,

    This is truly a bizarre situation, I believe there is indeed a misconfiguration somewhere that would explain the difference in the memory readings.

    On my servers it is absolutely accurate. That is my primary occupation servers and networks since 1998.

    The phpinfo display updated to the new figure, but when I went to test editing an existing page I received a fatal memory error.

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 19456 bytes) in /home/xxxxx/public_html/wp-includes/load.php on line 413

    I tested the php.ini file with the following values:

    128mb & 256mb but received the same memory error.

    It is my opinion that they have the memory allocated/capped somewhere else in the server/hosting environment probably using virtuozzo or something to that effect.

    In addition, the error message clearly indicated the process has run out of memory and therefore the error and the inability to edit pages.

    Therefore I would suggest you need a lot more memory then 64 MB’s and perhaps 128MB’s would be good if it is indeed available from real memory.

    Please advise.

    Cheers, Joe

  • member1
    • The Incredible Code Injector

    Thanks again Joe.

    If increasing/changing the memory limit in php.ini causes the memory error message, can you suggest another way to increase the memory without gaining server access?

    I’ve read that changes to the .htaccess file can help.

    thanks

    Paul

  • aecnu
    • WP Unicorn

    Greetings Paul,

    I am thinking that you got the error using your own php.ini file because of one of two reasons, either the server does not allow the use of your php.ini file in the home directory or you have indeed reached the allocated limit.

    Try adding this to an .htaccess file:

    php_value memory_limit 128M

    Try adding this line to your wp-config.php file:Increasing memory allocated to PHP

    define('WP_MEMORY_LIMIT', '128M');

    If these also fail to increase your php memory allocation, it will be necessary to get with your hosting provider.

    Please advise.

    Cheers, Joe

  • member1
    • The Incredible Code Injector

    thanks Joe.

    htaccess and wp-config code changes made no difference unfortunately.

    I’ll find a way to get onto my host I guess.

    I have a number of redundant sites, possibly a few plugins that I could delete to ease the pressure. Would this help in the short term?

    I also just noticed that attempting to access wp-admin.php page redirects to home page too. login.php is ok though.

    thanks again for your advice

    Paul

  • member1
    • The Incredible Code Injector

    Hang on Joe.

    I’ve just logged in and noticed that the Memory Limit using the usage plugin now shows 128mb – as per the htaccess and wp-config changes.

    phpinfo.php remains at 48mb though. ???

    The initial page publish redirection problem remains though. :slight_frown:

    Looking forward to your next suggestion.

    cheers

    Paul

  • aecnu
    • WP Unicorn

    Greetings Paul,

    htaccess and wp-config code changes made no difference unfortunately.

    Boooo! I was hoping that one of those would have worked out for you.

    I have a number of redundant sites, possibly a few plugins that I could delete to ease the pressure. Would this help in the short term?

    I do not think this will help at all being that the memory issue we are facing is for a single php action, not from combined actions of other sites or even of this site itself.

    True this specific sites plugins may be using some of the allocated memory causing it only leave the remainder available for execution of the next upcoming action which is the brick wall we are running into.

    I also just noticed that attempting to access wp-admin.php page redirects to home page too. login.php is ok though.

    This is a completely different issue here and we would need to go over your plugin to see if any are intentionally causing this.

    Are you using just http://yourdomain/wp-admin to get to this point?

    Have you reset your permalinks to anything other then default?

    Please advise.

    Cheers, Joe

  • member1
    • The Incredible Code Injector

    Are you using just http://yourdomain/wp-admin to get to this point?

    Yes, have had no problems accessing the login screen in this way in the past. SO there have been no other changes to reflect why this behaviour is occuring now.

    The solution to this is to contact the server host and address it. Unfortunately, I currently can’t access the account as in the past and I can’t contact the person who has access at this moment. I will have to persue this more deeply now to get to the bottom of things.

    unless you have any other suggestions, I’ll leave it here for now. thank you for your time in chasing this up. I really appreciate it.

    Paul

  • aecnu
    • WP Unicorn

    Greetings Paul,

    Thank you for letting me know.

    At this moment we are against a brick wall and if you cannot get a hold of your host within a timely manner or do not get satisfactory resolution, let me know.

    I will mark this ticket as resolved for now, but when you are ready to chase these items some more with me/us, just check mark the ticket as not resolved below and post what the situation is at that time.

    Cheers, Joe

  • member1
    • The Incredible Code Injector

    Thanks Joe.

    I was noticing that via WHM/Cpanel in the Server Status that I had a red alert next to the Server Load status (2.60 (2 cpus) )

    I checked on other sites on the server (via their cpanels too) and it registered the same.

    Does Server load have any bearing on memory limits?

    And in the wordpress world, what are the main culprits for an increased server load?

    thanks

    Paul

  • aecnu
    • WP Unicorn

    Greetings Paul,

    Thank you for this great question and a significant item to bring up.

    And in the wordpress world, what are the main culprits for an increased server load?

    Server load can be caused by everything and anything that involves the server.

    Everything from opening the cPanel page itself, to page views, to hackers trying to get into the server, to email inbound and outbound, to the server owner mismanaging the server putting too much load on it by too many domains.

    Any and all of these things contribute to server load and unfortunately many shared hosting providers do not care about the loads as they slam on more and more domains trying to squeeze every dime out of the server they can.

    Some hosting providers are much more sensitive to their clients experience like myself and limit the amount of VPS’s and shared hosting accounts allowed to one server.

    Does Server load have any bearing on memory limits?

    Only in the event that the servers real physical memory is being used up by all the sites on the server.

    We do not know if this is indeed causing your issue since if memory serves me well we have to date not been able to get a hold of your server administrator to see about bumping that memory up.

    Any news there?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Paul,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • member1
    • The Incredible Code Injector

    thanks Joe.

    I actually just got the whole thing solved yesterday.

    I ended up transfering my reseller account to another host and with 256mb memory instead of 48, all is in working order again.

    thanks for your help in identifying different options.

    Paul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.