Panino front end very slow

Hi there,
I have a bit of an issue with a local Wordpress install running on Xampp. And old version of the site most of the time ended up taking no less than 10 seconds to publish or just save a new post. Often it was more than 20 or even as bad as 30 seconds.

My Windows 7 was behaving oddly so I wasn't quite sure if that might have had anything to do with it. So, now with a 100% fresh Windows 7 and brand new Xampp installation I have tried setting up a new Wordpress install. Only plugins running are WP Fastes Cache and P3 for performance control.

If I run the site with Twentyfour theme it is fast a lightning. Average site load time according to P3 is 0.8 seconds. If I change it to Panino it drops to 3 seconds.
Now if this was only for lets say the startpage I might be able to live with that. But just trying to get a simple blog post to load takes apprx 3-4 seconds when I click a link in the front end versus probably under a second when I am running Twentyfour.

My old Wordpress install seems to run a tiny bit faster with the fresh Win7 and Xampp. But of course there is a lot more plugins chewing up time. But same here. Changing to Twentyfour solves most of the major slow downs.

Really got used to working with Panino/Upfront but this perfomance issue along with a lot of compatibility problems with a lot of plugins is about to kill it for me. Still hate to say goodbye to Panino for now.

Please help :slight_smile:


  • Vaughan

    Hi Peter,

    Hope you're well?

    Have you tried in combination with the hummingbird plugin? Utilizing Gzip compression & browser caching, as well as adjusting the minification options, that can give you an increase in site performance.

    In your Xampp php.ini settings, what do you have set for memory_limit & max_execution_time?

    it would be worth increasing memory_limit to 256M minimum & max_execution_time = 300

    memory_limit = 256M
    post_max_size = 128M
    max_execution_time =300

    Hope this helps

  • Peter

    Hi Vaughan,

    thanks for your quick response.

    I haven't tried Hummingbird yet - the first version actually slowed down the WP install when I tested it some months ago. I'll give it a shot, but the problem seems to be the theme. I've made two screenshots made with P3. It really seems to be Panino adding the extra time.
    (I was running some other tasks in the background this time, that's why both results are a little slower than before. But it's consistent with my overall experience so far)

    The screenshots were made running the new php.ini settings you suggested. The old values are in brackets.

    memory_limit = 256M (128M)
    post_max_size = 128M (8M)
    max_execution_time =300 (120)

  • Peter

    I revisited the issue after some weeks.

    It really looks like my Win7 setup is weird. Could have something to do with that bloody AMD hybrid graphics card that is giving me headaches with all kinds of things.

    For running Wordpress on a local install I finally tried Xampp, Wamp, Ampps and AppServ. And for whatever reason all but AppServ were having the same speed issues. AppServ on the other hand performs a LOT better. Very basic user interface and only Apache and MySql Server but works for me.