Parrot Installation from within WPMUDEV plugin gets error

Hi, I get an error every time I try to install the Parrot starter theme, even on a fresh installation of WordPress. It tells me it is most probably due to my wp-content file permissions - but if you read my support note, you will see that I did everything other Support Heroes suggested, but it still didn't work.

Thanks guys!