PARSE ERROR - PROTECTED CONTENT PLUGIN WILL NOT INSTALL

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/content/88/4611288/html/meatheads/wp-content/plugins/protected-content/app/class-ms-factory.php on line 207

Update (2:54 CST). We have updated our host to 5.3 as stated in previous support threads, and we are able to activate the plugin, but we still receive the same parse error on the admin(back end) of WordPress, that inhibits us from navigating the panel to manage our site.