Password Protect not working

I've tried Password Protect on two websites. For some reason, once the password is entered, the page refreshes but keeps the password field and button instead of revealing the content.

Inspector indicates (in Chrome and Firefox) that the password collection is insecure because our site doesn't have an SSL cert yet. Could this error be the reason the password doesn't work? Or should I be looking into theme/caching confllicts?

Thanks!

  • Rupok

    Hi Brian,

    So sorry to hear the inconvenience you are having. I tried to regenerate this issue on my test site but I could not. When I enter the password and click on the "Submit" button, the page reloads and reveals the protected content. My test site doesn't have SSL certificate installed but still, it's working fine. So I think, this is your site specific issue.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Caching could also be a probable reason behind this. Can you please try disabling caching and check if it resolves this issue?

    Moreover, I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know the result of your test and confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    P.S. I should add another point here, that is, WordPress now natively supports protecting posts/pages with password. So if you want to hide the full post/page, you can simply go to the editor, and then click on the "Edit" link beside "Visibility" option inside the "Publish" box on the right column. After clicking the "Edit" link, select "Password protected", enter a password and click "Ok", then save the post. It will make that post/page protected with password natively. Please check the attached screenshot for reference.

    I guess, this should help you.

    Have a nice day. Cheers!
    Rupok

  • Brian

    Rupok Thank you for the immensely helpful post.

    The reason your plugin provides value over the the native option is the ability to NOT lock the entire page/post. For example, with your plugin I am able to have multiple locked areas on a single page without barring access to the entire page. This allows me to include content alongside the locked areas.

    I'll work through your troubleshooting suggestions in our dev environment. If I can't solve it, I'll let you guys in.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.