Password Protect not working

So I tried using the password protect option and the set up was fine. In fact it successfully secured a blog on my network asking for authorization to view blog. However, the password though typed in exactly right still doesn’t let me in. And there is a link that says if you have a username log in however clicking that does nothing but refresh the same page asking for password.

Is there something I might be doing wrong? Thanks

  • Mike Price
    • The Incredible Code Injector

    Oh something to note here that is very strange. I signed up for a test account as a user normally would and have it set so they can create a password to protect their blog at signup. I did this and tested in new browser and sure enough the blog was protected

    However, again correct password failed to do anything. But what is interesting is that when im in the new test account’s dashboard and I click to view/change my privacy settings it does NOT show the Password protect bubble selected. It shows allow search engines to view my site. It is not somehow registering the fact that its supposed to be password protected even though it is still protecting them.

  • Mike Price
    • The Incredible Code Injector

    Hmm that sucks because blog templates is highly important for the type of network im setting up. The privacy protection by password sweetened the deal on top of that . Would love to think of some type of workaround or something in the code I could add to prevent this.

  • joan_donogh
    • Site Builder, Child of Zeus

    I think the privacy would be a setting, and the option is to copy settings, current theme and active plugins – which I expect you would want to copy. I have those 2 plugins activated too, but I haven’t tested it – I guess I better!

  • joan_donogh
    • Site Builder, Child of Zeus

    Yes, I am sad about this too. I also had a problem with the plugin that allows the user to set their tag line on signup, and found that it was not compatible with the New Blog Templates. However, the developer of the New Blog Templates plugin, Vladimir was very helpful and provided the code to make it work (exclude the tag line when copying the template) so hopefully he will be able to do the same thing here.

  • Mike Price
    • The Incredible Code Injector

    oh yes that would be great. something in the code that could say not to pay attention to multisite privacy setting..although i need this plugin to still carry over to new blogs so they can edit their privacy settings at any time from their dashboard..oh this will be tricky lol

  • Mike Price
    • The Incredible Code Injector

    So, I installed a plugin called “More Privacy Options” and it works beautifully even with the new blogs template but it does work a bit differently. I really really want to use your plugin because I like the idea of non members being able to view private blogs with passwords. please let me know when this is corrected or how I can do it on my end. Thanks :slight_smile:

  • Mike Price
    • The Incredible Code Injector

    Well that plugin didnt work like i wanted either but for different reasons..ok so back to this. I still dont understand why blog template would cause too much of an issue considering i set allow overide to yes for individual site admins to change their privacy settings.

    Also, I want to test this theory by deactivating blog templates but I will only do this if it keeps all my settings when I go to reactivate it. Will this be okay to do? Will my theme templates still exist when I reactivate it?

  • Mike Price
    • The Incredible Code Injector

    OK so I think i spotted a problem. Multisite Privacy plugin is storing my data even though I deleted the plugin and re-uploaded it via FTP. It kept my choices from when I had installed before. This means that when I messed it up the last time by hitting “Update all sites” (Like a dummy) and then not waiting for it and deleting it midway the update has now stored this error or info on my database which I think is causing this error.

    How can I completely remove all stored data from this plugin so I can install it completely fresh like I never had the plugin before? Thanks

  • joan_donogh
    • Site Builder, Child of Zeus

    I tried signing up for a site on my network and set it to password protected, and I do have the same problem – the settings show “public access” although the password I set is still showing, and when trying to use the password to access the site, it keeps looping back to the “Password required” page. There is an error message that comes up, but it loops back to the previous page so quickly I couldn’t get a good look at it. There was a warning message and then a “headers already sent” message.

    So it looks like the plugin is activated but because the Blog Template overwrites the privacy settings it is getting messed up.

  • Mike Price
    • The Incredible Code Injector

    Wow that is exactly what is happening to me Joan BUT here is the kicker. I completely deactivated blog template plugin and created a new account without the blog template. Guess what? exact same problem still existed with multisite privacy. I think the bug is in the plugin itself and not with a conflict of another plugin. I just think not enough people use it and those that do like yourself didnt know the bug existed.

  • Mike Price
    • The Incredible Code Injector

    Yeah I dont think the issue has anything to do with Blog templates as I see they updated the plugin today to be compatible with multisite privacy. but the update did not fix this issue just like deactivating the plugin did not :slight_frown:

  • joan_donogh
    • Site Builder, Child of Zeus

    Maybe it is just a coincidence that we are both using Blog Templates. I just downloaded the new version of it and Privacy still does not work. I managed to get a screenshot of the errors before it looped back to the login screen:

    Unable to parse URL in plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 493


    Warning – cannot modify header information – headers already sent (output started at plugins/sitewide-privacy-options/sitewide-privacy-options.php:493) in wp-includes/pluggable.php on line 876

    Also when logging in to the site, the Site Visibility settings are not what was entered on signup – it still has public access selected. Even when I change that to password protected it does not fix the issue, it just causes more headers already sent in sitewide-privacy-options.php and wp-login.php

  • joan_donogh
    • Site Builder, Child of Zeus

    I was testing it in Safari, maybe not all browsers would show the errors like that.

    I tried changing the settings to not ask for the privacy options on signup, thinking it might work when you changed the privacy options after the site had been set up (if it had anything to do with Blog Templates) but it still does not work, it is just broken.

    Unless there is some setting that we both have wrong in order to get it to function.

    Anyways, as you said, I hope someone will be looking in to this soon.

  • Mike Price
    • The Incredible Code Injector


    Dont waste your time LOL I tried messing around with each and every possible scenario with that plugin until I went crazy haha. Its just not functioning, period. no matter what setting you put on it. I hope someone sees this cry for help on this plugin! lol

  • joan_donogh
    • Site Builder, Child of Zeus

    Thanks for that Paul, But please note that we don’t think that the problem lies with Blog Templates, as per the notes above, but with the MultiSite Privacy Plugin iteself, so if you could also notify S H Mohanjith that would be great.

  • S H Mohanjith
    • Developer

    I can see the issue in your site but I cannot reproduce it in my test environment or many sites that use the plugin.

    Can you please let us know what other plugins you have activated and also what theme you have?

    You could also try to change line 50 in sitewide-privacy-options.php to the following

    add_action('init', 'additional_privacy');

  • joan_donogh
    • Site Builder, Child of Zeus

    I am having the same problem. The plugins I have activated are:

    BAW Login-Logout Menu

    Contact Form

    Fast Secure Contact Form


    Theme is WooThemes Whitelight

    Also network activated are:

    Anti Splog

    BlackStudio TinyMCE Widget

    Default Theme

    Domain Mapping

    Google Analytics

    MultiSite Plugin Manager

    MU Support System

    New Blog Templates


    Remove WP Dashboard Widgets

    Set Blog Description on Blog Creation

    Signup TOS

    Site Categories

    Testimonials Widget

    WPMU Dev Dashboard

    WPMU Dev Videos

    WP Resume

    I know that ThinkTaiwan has already tried a new install without New Blog Templates as we thought that might cause a conflict, but the problem still persisted.

  • Mike Price
    • The Incredible Code Injector

    Hey !

    Thanks for trying. I just woke up and saw your message. Here are my plugins that are enabled


    Avatars for Multisite

    Blog activity

    User activity

    Blogs directory



    Invite Friends

    Contact form widget

    Content Monitor

    Easy Blogging


    Multisite Analytics

    Infinite SEO

    Log in Message

    Log out Redirect

    Log in redirect (but its not set up to redirect to any url yet)


    New blog templates

    Post Indexer

    Recent Posts widget

    Remove email verification


    Ultimate Branding

    Set Password at sign up

    Plugins that are not from you guys:

    User Switching

    Easy FAQ with expanding text

    jj-WP easy navigation

    WP Notes remover (removes comment html)


    Theme: Licorice

    Thats it! Hope we can get this solved today!

  • joan_donogh
    • Site Builder, Child of Zeus

    We don’t seem to have many plugins in common – just New Blog Templates, which we have ruled out, and Contact Form Widget – and I don’t know how that could cause a problem with passwords, so I doubt if it is a plugin conflict. I have sent him my login info so he can go onto my server and see what is happening, You may want to send him yours also, or wait to see if he finds something on my server that can be fixed and applied to yours.

  • Mike Price
    • The Incredible Code Injector

    Thanks Joan for doing that. By the way to clarify something you mentioned earlier, I didn’t do a fresh install of wordpress without blog templates. What I did was is deactivate the plugin and create a new blog site on my network without blog templates being activated. I would think that a plugin being deactivated would prevent the potential plugin conflict though.

    Lets hope he finds something on yours that will be easily fixable.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.