Pay per view doesn't hide content

I'm trying to implement the plugin I'm sharing several screenshots.

But it doesn't work?! Is anything I'm missing?

  • Vinod Dalvi
    • WP Unicorn

    Hi @Jepser,

    Thank you for your question.

    Could you please make sure you have enabled protection for all posts from the Pay Per View settings on the following path or check in the post edit screen in Pay Per View section that the Effective status is enabled by selecting option in Enabled field to Always enabled?

    Admin area -> Pay Per View -> Global Settings -> Protection for posts

    Please advise.

    Kind Regards,

    Vinod Dalvi

  • Jepser
    • New Recruit

    But, enabling the Proctions for ALL POSTS, PAGE OR CUSTOM POST TYPE, will enable for each of them, and I don't want all my posts nor custom postype to be blocked?

    I'm attaching the status of the events post_type, the post I tested also has the same status.

  • Vinod Dalvi
    • WP Unicorn

    Hi @Jepser,

    But, enabling the Proctions for ALL POSTS, PAGE OR CUSTOM POST TYPE, will enable for each of them, and I don’t want all my posts nor custom postype to be blocked?

    If you don’t want to enable it for all posts then in Global settings disable it for all posts and in the individual post enable it making sure the Effective status is enabled.

    I have also tested it on my test site using the latest version of Pay Per View plugin but it didn’t work so I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advise for us.

    I have notified the developer about it an he will reply on this thread.

    Cheers,

    Vinod Dalvi

  • Arnold
    • El Macho WP

    First on your video embeds, Use the oEmbed that's built into WordPress. This is simple the share url from youtube on it's own line as text (not a link) in your page

    http://youtu.be/lEOHQQBZbJw

    If you need to control the size you can use

    [embed width=100]http://youtu.be/lEOHQQBZbJw[/embed]

    Much simpler than the iframe business. You can evenset the time in the video it will start playing by adding a bit to the url

    http://youtu.be/lEOHQQBZbJw?t=1m15s

    will start a 1 minute and 15 secs in to the video.

    On the PPV problem. Make sure it's Always Enabled for the page your on. If you are using the [ppw] shortcode around the content, make sure the Method is "Use Selection tool". I suspect the use selection tool setting is your problem.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.