Pay Per View Selection Tool Not Working

Can't get it to work. Want to protect content on PAGES. I am testing.

I want to use Selection Tool

This is what I've done on Settings:

1) I set up PayPal API stuff on Settings
2) I enabled Protection for Pages on Settings
3) I selected Selection Tool on Settings
4) My ONLY payment option selected is ONE TIME VIEW

This is what I've done on the Protected Page itself:

1) Enabled -- have tried both Follow Global and Always Enabled
2) Method - Selection Tool
3) I highlight the area I want protected and click the Green Icon and fill in description and price and update

The button doesn't show

here's link to the test page -- it's the latin I'm trying to protect
http://doublemychiropracticein90days.com/rapid-fire-strategies/

What am I doing wrong?

thank you!

  • mort3n
    • The Crimson Coder

    Hi FeleciaRose,

    I just went to the site. No latin, but there's a button :slight_smile:

    Though, when clicked it gives error

    There was a problem connecting to PayPal to setup your purchase. Please try again.

    10002 – Security error – Security header is not valid

    Hope this helps :slight_smile:

    Cheers
    Mort3n

  • aecnu
    • WP Unicorn

    Greetings FeleciaRose,

    Thank you for the great question and the first thing that comes to mind is are you running a caching plugin or perhaps not using two completely different browsers for testing? i.e. Firefox for developing and Chrome for testing dumping the cache and cookies from Chrome before each test.

    I am with Mort3n, I see the button as well (screen shot below) and the PayPal error is a credential issue i.e. possibly a space after one of the credentials?

    Please advise.

    Cheers, Joe

  • FeleciaRose
    • Site Builder, Child of Zeus

    OK -- pls tell me what a caching plugin is -- I suspect that's the problem

    I'm using two computers

    1) windows
    2) mac

    I'm building the website on the Mac --

    YESTERDAY the button didn't appear on any machine even after clearing cache

    TODAY -- the button is appearing on every machine and browser EXCEPT MAC AND FIREFOX

    I am using the MAC to build on and switch back and forth between Chrome and Firefox

    Thanks!

  • Jack Kitterhing
    • Code Norris

    Hi there,

    A caching plugin is something such as W3 Total cache etc, that caches your site so that when you visit it once, you'll see that same version till you either clear your cache or the plugin can be set to update at certain times etc.
    So rather than reload the whole page it shows a stored (cached) version, thus improving load times.
    If you are using a caching plugin, you may not want to use it on dynamically generated pages as it can cause issues, or a page that is frequently updated.
    Hope this helps.

    Kind Regards
    Jack (Coding-Monkey).

  • FeleciaRose
    • Site Builder, Child of Zeus

    Thanks Jack! I'm NOT using a caching plugin so we know that's not the problem

    PLS -- here's my problem again

    I'm using two computers

    1) windows
    2) mac

    I'm building the website on the Mac --

    YESTERDAY the button didn't appear on any machine even after clearing cache

    TODAY -- the button is appearing on every machine and browser EXCEPT MAC AND FIREFOX

    I am using the MAC to build on and switch back and forth between Chrome and Firefox

  • mort3n
    • The Crimson Coder

    Hi FeleciaRose,

    Just wondered whether you're logged in as admin on the Mac, but visit the site as a regular user on the PC? Some plugins treat an admin user differently than a regular user. I'm don't know if this is the case with this plugin, but give it a shot :slight_smile:

    It would explain the otherwise strange difference that we experience when visiting the site.

    Cheers
    Mort3n

  • Jack Kitterhing
    • Code Norris

    Hi there!

    Your settings are the same as mine with regards to Java, OSX and Firefox.

    I would also say the same as what @mort3n has said, the button may not appear for an Admin/Network Admin user. Make sure your not logged in to the site on your MAC and try again :slight_smile:

    Thanks!

    Kind Regards
    Jack (Coding-Monkey).

  • FeleciaRose
    • Site Builder, Child of Zeus

    BINGO! is was cause of being logged in as Admin. thank you so much :slight_smile:

    BUT as a rule of thumb because it took 24 hours for the button to appear anywhere I suspect it may be a good idea to private-publish a page 24 hours in advance of public-publishing content protected with Pay Per View???

    What do you think?

  • aecnu
    • WP Unicorn

    Greetings FeleciaRose,

    Thank you for letting us know this issue is resolved and if not logged into admin and using a clean browser i.e. cache and cookies clear - I would have anticipated that you would have seen the button.

    Before testing each time one should clear the cache and cookies and not be logged into the site or things like this can drive one bonkers ... lol ... not to mention adding the head games DNS caching can cause but that is a whole different animal.

    All of these items can be dealt with in one shot using CCleaner which is for both MAC and PC's.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.