Pay per View : Will not process anything through Paypal. Invalid Regular period. You must specify v

Hi there –

I’ve installed the Pay per View Plugin, and am getting a Paypal error:

Invalid Regular period. You must specify valid values for the A3, P3, and T3 parameters for a subscription.

for Daily Pass or Recurring Subscription.

I am also getting a WordPress error:

[Pay Per View] If you are using Daily Pass or Recurring Subscriptions, you need to enable and set API logins.

even when API logins have been set. Both errors display whether or not I have Facebook/Twitter login enabled.

The One-Time View gets to the last step of Paypal, then returns you to the previous page without ever processing a transaction.

Please help! Thanks!

Kelly

  • Timothy
    • Chief Pigeon

    Hey there, thanks for getting in touch.

    https://cms.paypal.com/cms_content/US/en_US/files/developer/PP_WebsitePaymentsStandard_IntegrationGuide.pdf

    Seems like you need to set your duration/price:

    a3 Required Regular subscription price.

    p3 Required Subscription duration. Specify an integer value in the

    allowable range for the units of duration that you specify

    with t3.

    t3 Required Regular subscription units of duration.

    Allowable values are:

    ? D – for days; allowable range for p3 is 1 to 90

    ? W – for weeks; allowable range for p3 is 1 to 52

    ? M – for months; allowable range for p3 is 1 to 24

    ? Y – for years; allowable range for p3 is 1 to 5

    If you can fill in those details please in the plugin settings please.

    Then try again with the rest of the settings.

    Let me know how that goes and if it doesn’t work then please include screenshots of the setup.

    Thanks.

  • KellyWhiteDesign
    • WPMU DEV Initiate

    Hi Timothy – Thanks for writing back! I changed the subscription length to 90 days and was able to go through to the payment screen. After I paid for a 90 day subscription, I got the following error when trying to return to the site:

    Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party.

    Is there a way to automatically return visitors to the website? I didn’t see an option in the Plugin settings?

    I received an email that the payment had processed, but when I returned to the website, content was still not able to be viewed (Still had the “Click to Subscribe buttons” displayed)

    The Daily Pass still does not work – it returns you to the home page without completing the transaction.

    thanks!

    Kelly

  • Timothy
    • Chief Pigeon

    Hey again.

    Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party.

    So you have https on the site?

    Can I see a screenshot of that please?

    The user should be returned automatically.

    Take care.

  • KellyWhiteDesign
    • WPMU DEV Initiate

    HI Timothy – No https on the website – it looks like it is going from Paypal https to:

    http://67.18.153.253/~truggwah/?auth=AKbeXE0P6BXAHIeK2YkM4ZzLKuTbksTJ96RUnCEDh22NMdy1NIngUtg1UVz.PCYeq8VIsCgeLSGlWszW4qsDZMw&form_charset=UTF-8

    which returns the customer to the home page and each page is still marked as Unavailable.

    The One Time View button does not process a payment at all.

    I had seen in another forum message that the redirect can get messed up due to Permalinks. Permalinks are not set up on this site, but it is a draft site that has not launched yet. Do Permalinks need to be set up prior to plugin working?

  • Timothy
    • Chief Pigeon

    “Confirm 0.25 USD payment to see this content”

    Is there a way to eliminate this button – it makes it sound like the user would need to pay again? I’ve changed the language of the button in the pay-per-view.php file to something else, but the button’s wording has not changed. The line I am changing is:

    Translations can be done with local through .po and .mo files. You will find the .po within the languages directory.

    http://codex.wordpress.org/Translating_WordPress#Translating_With_Poedit

    About Locales

    A locale is a combination of language and regional dialect. Usually locales correspond to countries, as is the case with Portuguese (Portugal) and Portuguese (Brazil).

    You can do a translation for any locale you wish, even other English locales such as Canadian English or Australian English, to adjust for regional spelling and idioms.

    The default locale of WordPress is U.S. English.

    You would setup the language just as if you were translating to another language, except it’s for local.

    I also noticed that the CSS for the buttons does not display in Internet Explorer. I’m attaching a screenshot

    I’d need a direct link for that so I can see what’s going on and if it might be theme related so we could recommend some CSS.

    Take care.

  • Timothy
    • Chief Pigeon

    Hey again.

    Just out of interest when charging $.25 won’t you lose money with with PP fees?

    https://www.paypal.com/webapps/mpp/paypal-fees

    2.9% transaction fee on the total sale amount plus a $0.30 fee per transaction

    Specifically the $.30 they charge per transaction?

    Just wondering. :slight_smile:

    Anyway, for the CSS please try this:

    input[type="submit"] {background: #5378B3 !important; color: #fff !important;}

    Joe could see this, so hopefully that should override what IE sees as the colours there.

    I’ve purchased the pass and, upon return to the site, am still seeing the “Buy Now” buttons with no hidden content visible.

    This happens on all browsers?

    Are you sandbox mode, if so then I should be able to test on your site to see what’s happening.

    Let me know.

  • KellyWhiteDesign
    • WPMU DEV Initiate

    I’m sorry if I was unclear – I changed the text of the button in the PHP file, not the language, but the text did not change on the site.

    Sandbox mode does not work at all, so I set the transaction amount to $0.25 for testing purposes.

    Internet Explorer, Firefox, and Chrome are all returning identical errors. I’ve updated the CSS file with the code above, but it has not changed the submit buttons in IE.

  • Timothy
    • Chief Pigeon

    As I was unable to look in IE I asked Kim and Patrick to look at this from their Windows machine.

    Patrick suggested this change:

    The colors here need to be adjusted:

    progid:DXImageTransform.Microsoft.gradient( startColorstr='#f8f8f8', endColorstr='#eae9e9',GradientType=0 )

    Let me know if that helps.

    Take care.

  • Patrick
    • Support Monkey

    Hi Kelly,

    Hmm… we need to give our custom style effort more weight it seems.

    Note that instead of adding theme-specific style elements directly in the plugin’s CSS, it’s best to add them to your active theme’s style-sheet. Or via the Custom CSS module in Jetpack… I love it! If you add them in the plugin CSS, you may lose your custom work when you update the plugin. (There’s a nice little write-up I did on that subject a while back here: wpmu.org/wp-plugins-custom-styles/ )

    Try adding the following with your color changes:

    div.ppw_form_container input[type="submit"] {
    progid:DXImageTransform.Microsoft.gradient( startColorstr='#f8f8f8', endColorstr='#eae9e9',GradientType=0 )
    }

    Hope this helps! And thanks for being a member :slight_smile:

  • KellyWhiteDesign
    • WPMU DEV Initiate

    Unfortunately, that did not work either. Is there any way to eliminate the gradient and/or styling and just have a solid color button?

    Also – most importantly – is there any progress being made on getting the Daily Pass to work? I’ve mentioned that it hasn’t worked since I’ve installed the plugin, and have not heard anything on this.

    It will charge the site visitor, but return them to an unpaid screen.

  • Patrick
    • Support Monkey

    Hi Kelly,

    OK, found the problem.

    The style rule you added to front.css has an incorrect syntax. This is what was added at the end of your file:

    progid:DXImageTransform.Microsoft.gradient( startColorstr='#0066cc', endColorstr='#00458A',GradientType=0 )

    This is what the current style rule looks like:

    filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#f8f8f8', endColorstr='#eae9e9',GradientType=0 ); /* IE6-9 */

    Notice the missing element: filter. That’s my error :slight_frown:

    Simply remove what you added, then go to around line 43 in front.css to adjust the colors to your liking.

    Alternatively, and IMO this is a better way, add a new style rule to your theme’s style-sheet (style.css). This way, when you update the plugin, it won’t get overridden. Here’s what you would need to add (and adjust the colors):

    a.payperview-login_link-cancel, .ppw_submit_btn {
    filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#f8f8f8', endColorstr='#eae9e9',GradientType=0 ); /* IE6-9 */
    }

    I also noticed that you are not using a child-theme. I highly recommend that you create one and activate that if you are going to be doing more customization (and obviously add custom styles to the child-theme style-sheet). If not, when you update your theme, you will need to redo all your work.

    Hope this helps! And thanks for being a member :slight_smile:

  • KellyWhiteDesign
    • WPMU DEV Initiate

    Could I please get a status or response on the Daily Pass section of this plugin? I’ve repeated multiple times in the last 2 weeks that it does not work, that site visitors pay, and are returned to the site without the ability to access paid content, and have heard nothing.

  • Timothy
    • Chief Pigeon

    Hey there.

    Really sorry about the delay here.

    The issue with having multiple issues within a single support thread is that one can be missed. We normally ask for separate issues to have their own threads.

    I’ll have to ask Hakan as he will no doubt have a much better insight into this plugin than I, he’s pretty cool about these things :slight_smile:

    Thanks.

  • Hakan
    • The Incredible Smush

    Hi all,

    If daily-pass or recurring subcriptions are enabled, we should see:

    – Js files should be added to the header, but we don’t see it.

    – On the front end, we should see an area to login as we click on the button, we don’t see it.

    This looks like a theme fault.

    @kelly, please just switch to the default theme and see what happens.

    I have to note that themes sold on Themeforest have zillions of bugs.

    I hope they place a quality control system in the future.

    Cheers,

    Hakan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.