Pay with a like: About translation, and sub-menu(Custom)

Hey
How is going?
I hope you having good day.

I want ask you about translation.

I realized ,even if I have translated your translation file to my language(ja), following three texts were still written in English.
1 :smiley:o not include the post URL here. The post URL is automatically added by Twitter
(sub-menu:social button ? turning on tab menu Twitter?This text will show up)

2:id - This is the unque global number for the Pay With a Like element. You can make this a very large number like 987654321 to ensure it does not match an existing post ID.
(Sub-menu: Custom?This text will show up)

3: Pay with a like
(This is a icon's description of Pay with a like in text editor)

1 and 3 are quite important for me.

Please give me a suggestion.

And also, if possible, I don't want to show the sub-menu: Custom, because my customer will get confused)
Do you have any kinds of solution for this?

In addition to this????
I tried to use Pay with a like for Post content, but it didn't work.
Although, on page, it sometimes is working, it is still in accurate
Could you give me any suggestion?

I will give you a temporary access to my admin.

Please help me!

King Regards

KAZUKI

  • Adam Czajczyk

    Hello KAZUKI,

    I hope you're well today and thank you for your question!

    I checked your site and then took a look at plugin's code and it seems there may be a tiny bug in relation to these strings as they are present inside translation files but does't seem to be translated inside plugin.

    That said, I'm reporting this to the developer as he'll have to fix the plugin's code. Please note though that his response time may be a bit longer than mine here on forum as he deals with a lot of complex issues on daily basis.

    I tried to use Pay with a like for Post content, but it didn't work.

    Could you please elaborate on this a bit? It would be also great if you could give me a short step-by-step guide on where could I observer this on your site and how to replicate it so I could give it a try on my own test setup.

    Best regards,
    Adam

  • KAZUKI KIKUCHI

    Hellow Adam
    How is going?

    About translation, I am happy to hear this reply.
    In addition to the these three text.
    I found that "Automatic" in edit page, was also untranslated.

    In terms of the issue that this plugin didn't work, I will explain more specifically.

    In my case, after activation, I went to sub-menu(setting) and activated this plugin for Post and Page. At the same time, I disabled the setting that admin can see full contents for test purpose.

    Later, I moved to post content page, wrote some texst, published the content, then I realized all texts showed up, and this plugin didn't hide my text.

    I have surveyed by my own, and I understood that it seemed to be fine for pre-build content such as Hello world post type page.
    Meanwhile, when I typed Japanese texts by Mac keyboard for new post type content , this plugin didn't hide the text.
    I don't have a windows PC, so I am still not sure Whether this issue happens ,when I use a Mac.

    So, I expected that this issues might be happened for folowing three reasons.
    1: Japanese is a multibyte language.( Multibyte language is very very rare: only Japanese and Chainese) I have experienced some issues due to that Japanese is multibyte language.Some time Japanese language is not recognized as a string, because of multibyte issue.

    2: Unicode or Font problem. Your plugin might not to be applied to Japanese font and unicode.

    3:It might be Pc's problem, Mac or Windows.

    However, this is my expectation, and I actually have no idea.

    I must fix this issue for my customer.

    So, If you know more information, let me know.

    Cheers,
    KAZUKI

  • KAZUKI KIKUCHI

    Hey!
    I hope you having a good day.

    I thought that this support might have been forgotten, so I posted a comment again.

    But........I finally realized why my "pay with a like" was not working.

    It's definitely because I am using Japanese language.
    I changed the default language from Japanese to English( in WordPress's setting), and then I checked to see if "pay with a like" was working in my post written in English. This time, it worked.

    However, when I changed again from English to Japanese and posted new texts in Japanese.........this time it didn't work.

    So , please apply this plugin for Japanese language.
    Maybe multibyte problem.

    cheers

    KAZUKI

  • Nastia

    Hello Kazuki, I trust that you are well today!

    The Pay With a Like plugin have not been translated yet! Usually our members translate the plugins.

    You may find the "Pay With a Like" plugin"s translation page here and add the translation to a string you require:
    https://premium.wpmudev.org/translate/projects/pwal/ja/default

    Please note, with our new loyalty program for each translated string you will get 1 Hero Points which you can redeem in our future e-shop (coming soon!).

    Once you translate the string you can export the translate .po and .mo files and upload them into the path:
    /wp-content/languages/plugins/

    Please have a look at our short manual regarding plugin translation:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/translations/

    Let us know if you require any further assistance!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.