Payment error on payment page?

We have tried to put through a payment through our website but its come up with the following error? You guys know anything lie this before? :slight_frown:

Payment error: The transaction was refused as a result of a duplicate invoice ID supplied. Attempt with a new invoice ID

  • Sajid

    Hello Jay,
    Hope you are doing good today :slight_smile:

    Could you please provide more details about this issue ? What plugin you are using ? When exactly this error come up ?

    Also, did you checked for a plugin/theme conflict ? If no then please first try to make a plugin/theme conflict test as described in our getting support manual.

    If the issue persists, then please enable support staff access so we could take a closer look. To grant access go to WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Jay

    Hey Sajid,

    I'm not bad apart fro this coming up just before going home!! :slight_frown:

    I have granted access for you guys to have a closer look. We are trying to use Paypal Pro. We have had a couple of orders go through last week but today we have tried to put an order through ourselves and when entering all details and card payment the error says:

    Payment error: The transaction was refused as a result of a duplicate invoice ID supplied. Attempt with a new invoice ID

    which is very concerning as we would like to take customer orders through the website.

  • Sajid

    Hello Jay,
    Hope you are doing good today :slight_smile:

    PayPal is rejecting the order because invoice ID already exist and paid in the PayPal system.

    This means, you may be clicking on the checkout button twice or there is another plugin/theme that is trying to creating another invoice at the same time.

    First of all, to make sure its not a conflict, we will run a conflict test as described in our getting support manual. I would recommend doing it on a staging/development site if you have any.

    If the problem continues, then I think you should contact WooCommerce support immediately. They might have reported this issue already and would have fixed/workaround ready.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid