Payment Grid Placement

After a new user has registered, set up a site, activated the site, and then attempts to login, they go to a page with the payment grid. Unfortunately the payment grid is placed on a strange revision of the home page, with a modified title and the grid placed BELOW all the regular home page content.

It's not intuitive at all for someone to go to a page and have to SCROLL DOWN before they see what to do next. To them, it looks like they are just back to the home page.

I need to be able to place this information grid in a reasonable place where users can access it. Please help.

  • 3SixtyEvolve
    • New Recruit

    Hi ProSapien

    Renewed greetings from my support desk! I've tried to assist on one of your recent threads so far. Let's see if I can get you sorted with this problem as well.

    I totally agree, the payment grid should be displaying on it's own and not on a modified home page format. Can you provide me with a screenshot of your page hierarchy? Or a test user account that I can log in and see the flow of the pages? When setting up my own Pro Sites test environment it's very hard to recreate the same issues as you, since I might have a completely different setup, so it's better to rather see your settings that trying to recreate those things from my side.

    Also, I noticed that there's a large amount of white space on top of your logo when I'm browsing your site using FireFox and not sure if it was intended that way, but I didn't notice it on your screenshot, so I thought I would ask.

    I I look forward to receiving your feedback.

    Have a good day!

    GinaB

  • ProSapien
    • The Crimson Coder

    GinaB, what do you mean by "page hierarchy"? Not sure what to include. I will be happy to give you dashboard access if you can give me an email address. [The extra white header space doesn't show in the screenshot because I scrolled UP so that you could see where the payment grid is. Normally, you can't even see it without scrolling.]

    Aaron, that's great news. HOW do I set this??? The home pages isn't a template, it's just a regular WordPress page -- and I don't remember assigning the checkout page to anything. ??? But if you can tell me WHERE to reset the page, that may solve the problem.

  • ProSapien
    • The Crimson Coder

    Aaron, I found the link on the General Settings area under Checkout Page.

    For the record, Pro Sites is NOT using "the default page template of your theme." It is using the default temple WITH the home page html included. In fact, it is using the home page itself.

    When I click on "Edit Checkout Page" Pro Sites links me to the WordPress page that serves as my home page. I didn't set that page to be the checkout page and don't see a place where this selection is made. Pro Sites must have a setting that creates that link...

    To clarify, I'm using a very typical WordPress setup (found in Settings>Reading) that uses a static page as the front page display and puts the blog aggregate on a different selected page (I use "blog"). For some reason, Pro Sites is using the page selected as the front page as the checkout page. I need to find where/why it's selecting it.

  • Aaron
    • CTO

    Wierd, ok. No idea how that happened, possibly you set the page pro sites created on install to be the home page.

    You can force pro sites to create a new checkout page by temporarily trashing your home page, then resave the pro sites settings. You can then untrash your home page. A new page will be created with a slug based on your rebrand option.

  • ProSapien
    • The Crimson Coder

    So far did this:

    Trashed the home page.

    Saved settings.

    Clicked "Edit Checkout Page »" in General Settings. Got this message

    You can’t edit this item because it is in the Trash. Please restore it and try again.

    Clicked "Undo" to untrash the page.

    Clicked Clicked "Edit Checkout Page »" in General Settings.

    It still goes to the home page.

    Now I'll try creating a new home page (instead of untrashing) and see what happens.

  • ProSapien
    • The Crimson Coder

    Just saw your last message. YES, I saved the settings every time.

    Trashed home page. (Which causes popcred.net to 404)

    Saved network settings. (Edit Checkout Page » link still errors when this page is trashed.)

    Created new page.

    Pasted code into new page.

    Published new page.

    Untrashed old home page.

    Deleted homepage text from old homepage. (Now popcred.net only shows the login/modify text from the other thread.)

    Now the real test: I will reset the home page in Settings>Reading to select my NEW page as the homepage.

    The new page shows up as the home page. Yea! NO login/modify garbage at the bottom. Double yea.

    I change the new homepage to "no sidebars." Still works.

    Go to old homepage and change the title to PopCred Checkout. Everything still seems to work. Yea.

    Change old homepage to Checkout (was blogging-network). Still seems to work.

    Last step, changed the new homepage title to what the old title used to be. Wow, still seems to work. Yes.

    Looks to me like the Pro Sites checkout is pulling a particular page ID or something that was the same page ID of the old homepage and even trashing and resaving settings did not create a new one, it just threw an error.

    Anyway, now I think I just need to retest site setup!

    Thanks for sticking with me on this to get to the bottom of it!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.