Payment options displaying on front (static) page

I use a static page as our landing page. The Pay Per View payment option is displaying on the front (Landing) page even though I have "Enable on Front Page" selected to "No" in the general settings. I do not want to payment options to display on the front page, can you help?
Also can I change the color of the font on the payment options? The font color is White and hard to see

  • PC
    • WPMU DEV Initiate

    Hello there,

    Greetings and thanks for posting on the forums.

    I do not want to payment options to display on the front page, can you help?

    What is the link to your site where I can see that in action ? I just visited the site you selected while creating this ticket and could not see the payment options on the homepage.

    Also can I change the color of the font on the payment options? The font color is White and hard to see

    Yeah, you can surely do that. Just add the below CSS to your site and it will match the buttons on your site :slight_smile:

    .ppw_submit_btn {color:#ffffff ; background:#444444 !important}

    Please advise on the site link where I can see the frontpage payment options in action.

    Cheers, PC

  • PC
    • WPMU DEV Initiate

    Hello there,

    Thanks for posting back.

    I do still see the payment options on the front page. Bottom right hand corner.

    I see that too now. Can you tell me how is the homepage created ? Is that a widget area or what ?

    A closer access would be a nice idea. You can enable support access via :

    WordPress Dashboard >> WPMU DEV Dashboard >> Support >> Staff Access >> Grant Access.

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Please advise.

    Cheers, PC

  • Aurelio
    • WPMU DEV Initiate

    Mac,
    No widget area on home page, I do use a plugin called Magazine Columns to break up the front page into three columns. Also the Theme used is our (Child) of Magazine Premium.
    I could not figure out why the pay per view options were displaying on the front page even with the setting checked to "No" in the general settings. Last night I selected "Always Disabled" on the Pay Per View page options which seemed to stop the display on the front page. However, our plan is to have a "special" of some kind displayed on the front page which will require enabling the setting.
    I have granted support access for you, so you may take a look and see if you can find a conflict or problem.
    Thanks,
    Aurelio

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.