PayPal error after taking live - urgend help needed

Hi,
after publishing the website mit marketpress shop on:
http://www.maatka-re-kartenlegen.tv/shop-mr/

I get now Errors at the checkout with paypal:

There was a problem connecting to PayPal to setup your purchase. Please try again.
10401 - Transaction refused because of an invalid argument. See additional error messages for details. - Order total is invalid.
10426 - Transaction refused because of an invalid argument. See additional error messages for details. - Item total is invalid.
10413 - Transaction refused because of an invalid argument. See additional error messages for details. - The totals of the cart item amounts do not match order amounts.

I've also refreshed the API information at paypal directly. But the issue seems to be at another place. Also updated to the latest release.

Please let me know how to fix the issue.
Thanks a lot !
Greetings
Michael

  • Michael
    • WPMU DEV Initiate

    Hi Ari,
    thanks a very lot for this hint ! This is really hot !!!
    I have a baxically problem with decimals:

    1) Without decimals, everything is working.
    2) If I type in 39 comme 95 => 39,95 after pressing update I get 3995.00
    3) If I type in 39 dot 95 => 39.95 the error is occuring.

    But my client needs at two prices the comma95 because of contract obligations.
    Can you please give another hot hint how to solve ??

    Thanks a lot !
    Greetings
    Michael

  • Michael
    • WPMU DEV Initiate

    Hi David,
    thanks a lot for this also as at the reffered topic it's not ecplained more in detail how to change.
    Nevertheless I took the de_DE.po File and deleted the number_format_thousands_sep
    also I changed the number_format_decimal_point to a DOT.
    I updated the price in the shop again to be at save side.

    But error occurs still at prices with decimals.

    Please let know what to do to fix the issue. Also admin access to staging can be given, to sort out if needed. My client needs the decimals and at time I'm lost what to do.

    So thanks a lot for your help in advance !
    Greetings
    Michael

  • DavidM
    • DEV MAN’s Mascot

    Hi Michael,

    Thanks for your reply. Could I ask how you made that change in the language file? Was it through Poedit and did you then export as noted here?
    http://codex.wordpress.org/Translating_WordPress#Translating_With_Poedit

    Also, do you have your wp-config.php file setup for the language as here?
    http://codex.wordpress.org/Editing_wp-config.php#Language_and_Language_Directory

    Looking forward to getting this sorted for you. :slight_smile:

    Thanks,
    David

  • Michael
    • WPMU DEV Initiate

    Hi David,

    thanks for your response. Yes it's really valid to ask how I've done.
    So Language file I've done with POEDIT. I attach also the files.

    At the WP Config second my opintion the settings are correct. It's an original german version:

    /**
     * WordPress Sprachdatei
     *
     * Hier kannst du einstellen, welche Sprachdatei benutzt werden soll. Die entsprechende
     * Sprachdatei muss im Ordner wp-content/languages vorhanden sein, beispielsweise de_DE.mo
     * Wenn du nichts einträgst, wird Englisch genommen.
     */
    define('WPLANG', 'de_DE');

    Thanks a lot for your help !
    Greetings
    Michael

  • DavidM
    • DEV MAN’s Mascot

    Hi @Michael

    Thanks for providing those details. Have you also exported the .mo file and placed it in /wp-includes/languages/ as described here?

    http://codex.wordpress.org/Translating_WordPress#Using_Localizations

    With the .mo file named properly (de_DE.mo I believe it should be), it should just work.

    MarketPress itself just makes use of the thousand separator and decimal point specified there, as per WordPress' built-in number function.

    In my own tests, it works great. Just need to make sure to export the translated .mo file and place it in the /wp-includes/languages/ folder with that proper name.

    Cheers,
    David

  • Michael
    • WPMU DEV Initiate

    Hi David,
    thanks for kind support:
    Basing on my wp-config:

    /**
     * WordPress Sprachdatei
     *
     * Hier kannst du einstellen, welche Sprachdatei benutzt werden soll. Die entsprechende
     * Sprachdatei muss im Ordner wp-content/languages vorhanden sein, beispielsweise de_DE.mo
     * Wenn du nichts einträgst, wird Englisch genommen.
     */
    define('WPLANG', 'de_DE');

    The language file has to be in the folder: wp-content/languages.
    And this is source by wordpress original installation.

    Does Marketpress expect the language file in "/wp-includes/languages/ " ?

    The de_DE.mo and po File attached.

    Please let me know what to try in next step.

    Thanks a very lot...
    Greetings
    Michael

  • Michael
    • WPMU DEV Initiate

    Hi David,
    thanks again for pointing out this:
    So now I created also a folder in wp-includes named languages as described at the refferd link. Uploaded the po and mo file also there without any change.

    Also now I checked again the german Language file.

    I loaded the en_AU language file to check if it's working with that to have a kind template for configuration of the german files. With en_AU it's working.

    Then I checked the setting in the language files of en_AU regarding:
    number_format_thousands_sep
    number_format_decimal_point

    In the translation of these two files are writte exactly the same words:
    number_format_thousands_sep
    number_format_decimal_point

    So done the same in the german file but also this doesn't work.

    What is the correct setting of these two parameters:
    number_format_thousands_sep
    number_format_decimal_point
    ?
    Or do I have to consider another paramete?
    I also checked the translation of the theme, but there is none of the parameters set.
    Or do I have to set a parameter in the german translation of the marketpress language files?

    I attache the WP and Marketpress Language file. Hope in ZIP format it will work.

    Thanks a lot for your kind support.
    Greetings
    Michael

  • Michael
    • WPMU DEV Initiate

    Hi
    now also changed in wp-includes the locale.php at

    /* translators: $thousands_sep argument for http://php.net/number_format, default is , */
    		$trans = __('number_format_thousands_sep');
    		//$this->number_format['thousands_sep'] = ('number_format_thousands_sep' == $trans) ? ',' : $trans;
        $this->number_format['thousands_sep'] = '';
    
    		/* translators: $dec_point argument for http://php.net/number_format, default is . */
    		$trans = __('number_format_decimal_point');
    		//$this->number_format['decimal_point'] = ('number_format_decimal_point' == $trans) ? '.' : $trans;
        $this->number_format['decimal_point'] = '.';

    So disables the translation of these two parameters completely second my opinion. But same error occurs...
    I' getting crazy with this bug.

    Thanks for your help in advance !
    Greetings
    Michael

  • DavidM
    • DEV MAN’s Mascot

    Hi Michael,

    You should be able to include .zip files here, is the extension .zip? Also, the file size needs to be under 5MB, is that the case?

    Also, changing core files isn't recommended here, but I see you might just be doing that for testing purposes.

    In my own testing with this, I did the following:
    1. Edited the original language file (en_US.po in my case).
    2. Exported the en_US.mo file.
    3. Created a /languages/ folder in /wp-includes/ and placed the en_US.mo file there.
    4. Change the language in wp-config.php to en_US.

    With that, the price displayed with the adjustment for the thousand_sep and number_format_decimal_point.

    Just to check, have you actually exported your changed version to the .mo format?

    By any chance, do you have caching in place on your site? Is it possible you're not seeing changes due to caching?

    If that doesn't sort it, could you grant me admin and ftp access to see what the issue is? You can send through details using the contact form:
    https://premium.wpmudev.org/contact/

    Just include "ATTN David" in the subject then a link to this topic in the message along with other details.

    Thanks,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.