Paypal error ( code 520003 ).


I tried a test project and when I pledge, I've this error : There was a problem connecting with the paypal gateway. (CODE)520003 Authentication failed. API credentials are incorrect.
Sandbox mode, API username, API password and signature are enabled.

Any idea ?


  • aecnu
    • WP Unicorn

    Greetings jeroulevert,

    If in fact that the credentials are not without error as Rob hinted to as a possibility above, I would give live mode a shot because many times here when folks were having trouble with sandbox mode and I had them go live for a test it worked flawlessly.

    Please advise how live goes if you do indeed choose to test it, the results may surprise you :slight_smile:

    Cheers, Joe

  • Cole
    • The Incredible Code Injector

    Also make sure you are logged into before you try to use sandbox mode. When your in sandbox mode its also not required to have an Application ID, a universal one is hardcoded into the paypal gateway.

  • aecnu
    • WP Unicorn

    Greetings jeroulevert,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • rigonatti
    • Flash Drive

    I have the same problem.

    What I did:

    Logged in Paypal,
    Create a API under >> Setting up API permissions and credentials

    Went back to Fundraising
    filled in: username, password, and API signature (copying and paste to make sure that didn't have any typo)

    Currency is: Brazilian

    and application ID its empty.

    PaypalMode: Sandbox

    Error returned:
    (CODE)520003 Authentication failed. API credentials are incorrect.

    The URL its:

  • morten_r__nseth
    • New Recruit


    Having same issue. Just installed MarketPlace, inserted my sandbox credentials, logged into PayPal Sandbox with my test-biz user and tried to check out.

    Just clicked on the paypal logo, and then a window opened showing the content of the transaction. Looks like MP is accessing the live paypal solution, not sandbok, even though I'v clearly selected sandbox and saved setup.

  • Argancel
    • WPMU DEV Initiate


    Same issue here.

    I hope this won't cause any problem for my application for the application ID I just did today.

    I tried also to use the sandbox ID I have been given by paypal, but did not work better, filled or not filled.

    I doubled checked every fields of the signature. I am 100% sure it is well field.

    I have put "Paypal" as gateway, sandbox mode. Everyhing is fine, execpt that I get this error :
    Votre contribution d'un montant de 4 € est presque achevée.
    There was a problem connecting with the paypal gateway. (CODE)520003 Authentication failed. API credentials are incorrect.

    I also tried your solution (connect to paypal sandbox with my test user before making the test). This is not better.

    Please, can you give detailed step by step to resolve this issue ?


  • Argancel
    • WPMU DEV Initiate

    Hello Cole,

    I received today a notice from x commerce saying that my request to receive an "application ID" cannot be processed because of the error I just mentionned in previous post.

    I still could not figure out a solution to fix this problem.

    I even looked at the code to try to debug myself, but could not make it work.

    In fact I found another bug that you should correct promptly in the following file : \fundraising\lib\gateways\paypal.php

    Line 125 :
    $nvpstr .= "&currencyCode=" . esc_attr($settings['paypal']['advanced']['currency']);

    You see, the expression "&curren" is an html entity. So it gets interpreted as character ¤, which is wrong.

    To fix this problem, you should replace it by :
    $nvpstr .= "&currencyCode=" . esc_attr($settings['paypal']['advanced']['currency']);

    But this fix did NOT resolve my problem.

    Please can you give detailed steps to find out how to resolve this annoying issue ?

    I have a crucial deadline next week, I need to make this work.

    Kind regards

  • PC
    • WPMU DEV Initiate

    Hiya @Argancel

    Greetings and thanks for being a great community member.

    Could you please update to the latest Fundraising 2.2 release and see if that resolves the issue ?

    If it does not, please feel free to reopen the thread by marking it as not resolved so that we can be back on it.


  • benjamin_holman_richards_iv
    • New Recruit

    Hi. I am getting the same error. I have tried all of the suggestions found in the online forums - created new Application, new API credentials...etc I have also ensured that my Paypal account is verified, a Business account and confirmed with a Bank Account.

    The only detail I could be missing is that I don't have an active SSL on the domain. Can this cause the problem?

    I recently paid for the subscription (again) so I could download the update.

    I have tried Sandbox, Live and I've started over many times taking it step by step following the support Doc.

    Please HELP!!!

  • aecnu
    • WP Unicorn

    Greetings benjamin_holman_richards_iv,

    Welcome to WPMU DEV.

    Though this may seem like a similar issue which it is indeed possible, you have responded to a ticket that is several months old and several releases of the plugin have been made since that time.

    Therefore I respectfully request that you open your own ticket and feel free to copy and past any relative information into the new ticket from this closed one as you see fit.

    Thank you for your understanding and for being a WPMU DEV Community Member!

    Cheers, Joe

  • flippy
    • New Recruit

    I got the same error at first but I think I´ve solved it.

    Create a test account in Paypal Dev. There you can also get test API credentials. Add those to the Fundraising settings and choose Sandbox-mode.

    It worked for me.

    One thing I still dont have working is the Simple donations-function.
    I get to the Paypal sandbox but when I´m taken back to my site, it just says "Oh no...we cant find your gift..."

  • aecnu
    • WP Unicorn

    Greetings flippy,

    Welcome to WPMU DEV!

    Thank you for your additional input which is greatly appreciated.

    Due to the fact that most of the time the PayPal sandbox gives erratic behavior at best, I would suggest jumping into live mode and see if that does not resolve your issue.

    If that does not work please create your own ticket feeling free to copy and paste any relevant information form this ticket into the new one.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

  • John
    • Site Builder, Child of Zeus

    I've had the same problems using Sandbox for Paypal Adaptive, and as soon as I went into "live" mode as suggested by those above it connected me with no issue or error message, processed the transaction as it should, and redirected back to the website as it should to show details of the order.

    It's somewhat counter-productive that Paypal would provide a test environment for you to ensure everything is working properly before the site goes live, but won't give final approval until your site is live yet you can't accurately test with Sandbox (remains "Status: Approved Conditionally" until they can verify site information on the user agreement pages)?!?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.