Paypal Sandbox - Says success but not subscribed?

Hi! I've got the "Paypal Express" membership gateway active: http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.08.42%20AM-bFoOM6P8Ai.png

It's set to be sanboxed:
http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.09.13%20AM-7TERVvfvtq.png

So, I go through the paypal steps to check out. Here, I'll sign up for my "Training" membership level @ $99/month. Here's the step-by-step of screens that I see:

1. http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.10.02%20AM-QUvKtXr2JE.png

2. http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.15.47%20AM-xchFvTVomM.png

3. http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.16.04%20AM-JJ0IRq2Jqy.png

4. http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.16.18%20AM-aLM8ON9ET0.png

5. http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.16.26%20AM-qkofbrZX6P.png

6. http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.16.42%20AM-juUg7w9QPz.png

That last screen is the default 'welcome' screen that gets generated for me.

So, everything APPEARS to go well, but I visit my "subscriptions" and I see:
http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.17.28%20AM-NXdwAhjpYy.png

:slight_frown: Same result in the admin:
http://www.otleylogic.com/screenshots/Screen%20Shot%202014-01-10%20at%203.17.53%20AM-6qL6YJOX4Y.png

Help!