Per the folks at WPEngine: I've disabled the "popover"

Hello,

Per the folks at WPEngine:

I've disabled the "popover" plugin. It's running this query, which alone takes 20+ seconds to complete.

SHOW TABLES LIKE 'wp_7331_popover';
Your development team either needs to enable object caching so that the value doesn't have to be calculated over and over again, or reach out to the developer of the plugin to correct this issue. Here is a helpful guide on object caching:

http://codex.wordpress.org/Class_Reference/WP_Object_Cache

Best,
Aaron

  • Barry
    • DEV MAN’s Mascot

    It should only be running that query once to see if the table exists before creating it, after that it sets an "installed" flag and then should never run that again. So if it is repeatedly running then it suggests something else is happening that is preventing the plugin from setting or reading that flag.

  • Tom Eagles
    • Syntax Hero

    @Aaron

    This is a hosting issue rather than a plugin issue we have 1000's of users using this plugin with out problems. Now if my host is taking 20 seconds to run a query i would be looking for a new host.

    However in the spirit of trying to resolve your issue I will pull in the developer @Barry to comment on this and see if this could be done in a future update. But as i mentioned hosting and hosting response times is something we have no control over and this is the first time I have seen this issue raised.

    Kindest regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.