After running optimization, my performance score went from 74 to 45. Can you tell why that happened?

  • Nastia

    Hello Steve

    Hope all is well!

    I've visited your site and based on the latest performance report Leverage browser caching score needs to be increased. Please go to Hummingbird > Caching > Browser Caching and enable it. See attached screenshot:

    Some original images needs to be optimized. Here the WP Smush Pro plugin can do this for you:

    After the plugin is installed and active, please enable:
    - Super-smush my images
    - Strip my image meta data
    - Resize my full size images ( add the suggested dimensions)
    - Smush my original full-size images

    Optionally enable Make a copy of my full size images, to restore images back after optimization. At the end, run Bulk Smush to optimize images

    To improve " Remove render-blocking resources" score, please try changing the font-awesome.min.css file position in to the footer. See attached screenshot:

    Refresh the front end page and see if all is well.

    Let us know how it went!

    Kind regards,

  • Oguz

    Hey Steve ,

    Hope you're well.

    When I check your website, I can still see the problems not solved that Nastia mentioned (gzip, minify, browser cache etc..). Can you check those settings okay and clear cache for both Hummingbird and from the server if you are using any caching system from the server? If still not solved, maybe if you can come to live chat support and we can check together.


  • Dimitris

    Hello Steve,

    hope you're doing good and don't mind me chip in here! :slight_smile:

    A broken site can only be happened via the Asset Optimisation module of HummingBird, as it grabs all CSS and JS files coming from core, theme and plugins, and proceeds with some functions like compression, combination and change of order, so site loads faster.
    Due to the nature of some plugins though, their coding practises and compatibility between them, having all assets (CSS and JS files) to use all above functionalities, may break the frontend of website. That's why it's always advised to:
    - first complete any development you have doing
    - while developing, deactivate all caches too
    - when development is done, enable Asset Optimisation, start making changes in batches (you can also filter assets by theme or plugin) and check the homepage
    - if something goes off, revert last changes and proceed with next batch

    For more info on this HummingBird module:
    Specifically for render-blocking issues, reported by Performance Report, that can be handled via Asset Optimisation (former Minification):

    As for the errors happening now in your homepage:

    1. For the 500 Internal Server Error we will need some additional info, as the error message is pretty generic. First, deactivate any caches and Asset Optimisation altogether, so we're sure we're getting the live content and not some cached copy. Then access your server via (S)FTP, edit wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    @ini_set( 'log_errors', 1 );
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error, by visiting the homepage on your browser once more.
    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.

    2. About the Mixed Content errors, these are happening because you're having a https:// domain, trying to load http:// links. In order to surpass that, you can use a little plugin, to force all links to use the https:// protocol.

    Finally, I'd like to mention that I wasn't able to use the granted support access to have a look in WP admin area, as I'm getting a HTTP ERROR 400. I don't know if this is happening due to ongoing issues, please try once more to go to WPMUDEV -> Support, revoke access, then re-grant it.

    Warm regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.