Performance Issue & CloudFlare error

1) Trying to a run performance scan, and getting the following message:
The performance test didn't return any results. This probably means you're on a local website (which we can't scan) or something went wrong trying to access WPMU DEV. Try again and if this error continues to appear please open a ticket with our support heroes

2) Getting fatal error in the Browser Caching page, under Hummigbird > Caching > Browser Caching

Catchable fatal error: Object of class WP_Error could not be converted to string in /xxx/wp-includes/general-template.php on line 4232

Warning: explode() expects parameter 2 to be string, array given in /xxxx/wp-content/plugins/wp-hummingbird/core/modules/class-module-caching.php on line 183

  • Adam Czajczyk

    Hello Pivot Digital,

    I hope you're well today and thank you for your question!

    I have checked your site. We've been experiencing some issues with Performance Test API and while it should be better now, it might still need a bit of time to get back to normal state. I have tried to run the test on your site now but it gave the same error so please give it a couple hours "rest" and try again later. If it still doesn't work, let me know please.

    As for the fatal error. It seems that options for HB got slightly corrupted but I was able to reset default options to initial state and the error is gone now. Browser and Gravatar caching works fine, no errors there and I think it should be okay now. You might however want to review Hummingibird settings to make sure that it's set as it was (if not, you should be able to set it back to your needs with no further errors).

    Kind regards,
    Adam

  • Pivot Digital

    Hey Adam,

    Hummingbird is now running performance tests but they're not making sense. I'm getting great scores on everything except image optimization. Image optimization is 1/100 while everything else is 99-100/100. None of the scores make sense.

    There is only one image recommendation in image optimization and I've taken care of it. I'm not sure what else to do.

    Thank you for figuring out the fatal error. I rest my settings without any issues.

  • Adam Czajczyk

    Hello @webmaster42729!

    I'm glad I could help in getting that to a working condition again :slight_smile:

    As for the image optimization. I checked that and that's indeed as single image. However, it's 5472 x 3648 pixels in size and the file weights over 8MB. That's really a big image.

    I see it's loaded on front page (home page) as a background via CSS and is significantly resized via browser. Furthermore, it also has some sort of blue(ish) overlay over it so the quality wouldn't be as important in this case as with any other images. I think I would take a bit more care of that image.

    If you check your main site with PageSpeed Insights, you'll notice that it's actually getting the same score for the desktop view.

    There are two issues here: one is image optimization and the other one is resizing it. I'd run WP Smush over it (and it would mean enabling "smush my original full-size images" option as otherwise the image wouldn't be affected at all by smush optimization) but first, I'd resize it manually and I think making it half the size it currently is (of course maintaining aspect ratio) wouldn't still made a difference in visual perception of it but together with smush optimization should increase the score and speed up the site actually (loading > 8MB image on a homepage is definitely a bit "speed eater").

    Kind regards,
    Adam