Performance related issues

Hello,
First of I have started the membership yesterday, 27/9/2018. Please correct this information accordingly.
Second, we have done some of the suggested settings and improvements by despite a decrease in the size of our website we are still experiencing a significant performance and speed issues. It takes ages for the site to load and perform.
It will be great if some of your experts can look at this matter and help us in solving it.
Please note that this is a live site.
Thank you for your prompt reply and action.
Best
A.

  • Predrag Dubajic

    Hey Aleksandar,

    Hope you're doing well :slight_smile:

    First of I have started the membership yesterday, 27/9/2018. Please correct this information accordingly.

    I'm a bit confused about this, today is the 27th and you have started your trial yesterday, which also shows in your account from our end.
    If you're seeing something different can you get in touch with our account people here https://premium.wpmudev.org/contact/#i-have-a-billing-question as they have more insight to your account and can help you more about that :slight_smile:

    Second, we have done some of the suggested settings and improvements by despite a decrease in the size of our website we are still experiencing a significant performance and speed issues. It takes ages for the site to load and perform.
    It will be great if some of your experts can look at this matter and help us in solving it.

    Could you tell me which of the optimization performances you have done so far, or grant us support access to your site so we can check your settings?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    I did also run a page speed test on Google so here's what I see in there that could be improved.

    Let's start with image optimization.
    Page speed tests have two types of reports for image optimization.

    1. Compressing and resizing - This tells us that image is larger than its actual HTML holder.

    For example, on your home page in sections below Solutions there are 1600x1066 images loaded but the actual HTML holder of that image is only 540x360 so the image is resized with CSS to fit in that holder.

    Unfortunately, this is not something Smush can deal with yet since the theme code is written in the way to call the larger image, and even though the image is compressed speed test doesn't like when the loaded image is larger than its holder, so this is something you need to check with the theme devs.

    You can read more about this on this blog post:
    https://premium.wpmudev.org/blog/compress-resize-images-wordpress/

    2. Compressing - This one's is telling that image can be optimized, and it seems all of these reports are for your 19x5 and 11x5 icons.
    I would like to have a closer look at this in Smush settings if you could grant access as mentioned above.

    Next thing in the report is "Reduce server response time", this can be slightly improved by enabling page caching but it's mostly affected by the server itself and which time it takes to respond to a browser request, so I would suggesting discussing this part further with your hosting provider.

    Then we have "Leverage browser caching", and this should be resolved by enabling Browser Caching in Hummingbird > Caching panel.
    Note that there are a couple of resources at the end of the report that are not loaded from your server and these can't be affected on from your end.

    Last three reports are "Eliminate render-blocking JavaScript and CSS in above-the-fold content", "Minify CSS" and "Minify JavaScript".
    I've grouped all three of these becasue this can be improved from Hummingbird > Asset Optimization panel.
    You would need to enable asset optimization and then tweak the settings of your files, this can be a bit tricky as some files don't handle well being minified or loaded in footer so you would need to test it out and find what's the best combination for your site to get the best results while still keeping your site functionality intact.

    In addition to that you also have quite a few scripts on your site, for the wave effects and I'm guessing live updates on header tabel, then there's also iframe loading the purchase form down the bottom, and so on.
    So there are a lot of "little" things going on on your site but when you add them together on your page it will affect it's speed and performance.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Aleksandar

    Thanks for enabling support access!

    I checked your site's setup and in addition to Predrag's suggestions I also got additional remarks on this.

    1. Those small images that Predrag mentioned that are not optimized - they don't seem to be registered with WordPress which means that Smush "doesn't see" them. I'm not sure why it's that but it's possible that they might have either been uploaded directly to the server (not via Media Library) or they were registered as image sizes before but no longer are.

    Try finding these images directly in Media Library and if they are there, there should also be a "Smush now" button next to each of them. If yes, use it and it should do the trick.

    If there's no "Smush now" button next to them or you can't find them in Media Library, that'd be a bit more tricky. The way to deal with that would be to actually download all these images first, re-upload them to the site via Media Library (smush should automatically optimize them then) and then replace them in with those newly uploaded in every place on site where they are used. However, this might be difficult to do and, to be perfectly honest, I wouldn't worry much about these particular images as it's very unlikely they are affecting speed in a significant way.

    2. There is a server-side caching enabled and I wouldn't rely on it, in this case. It might also interfere with both Page Caching and Asset Optimization of Hummingbird. I would suggest this:

    - in Hummingbird disable Page Caching and Asset Optimization
    - go to "Settings -> General" page and at the very bottom of it set "Cache Level" option in "Endurance Cache" to "Off Level 0"
    - go back to Hummingbird, enable Asset Optimization and use "re-check files" option there

    Once that process is complete, switch Asset Optimization to "Advanced" mode and try to minfiy, combine and move to footer/load after the page is loaded as many JS and CSS resources as possible without breaking the site. That's what Predrag suggested and it, unfortunately, may be a time consuming and sometimes a difficult task as every site is different and it takes a lot of experimenting to get that all configured. The best way to go is to set a couple of files to be miminized, let them minimize, check the site. If the site's fine, proceed with next few but if not, experiment with enabling/disabling minification of those that you just enabled. The same way proceed with other options in Asset Optimization.

    Once you got that configured, enable Page Caching in Hummingbird again and after the cache is rebuilt the site should be faster.

    Also, make sure that you followed Predrag's suggestions on that.

    One more thing that I would like to suggest too would be to review plugins that are currently active on site. I noticed that there are some that you're most likely not using at all or not using currently (e.g. plugin for PHP info) - such plugins should be disabled if you're not using them so they wouldn't "add up" to the site load.

    There are also some other plugins that might be slowing down the site because they actually fetch data from external sources. While I can't say much about them, it might be worth looking for some alternatives to them in form of either some other plugins of the same features (if possible) or even more 'custom solutions'.

    Best regards,
    Adam

  • Predrag Dubajic

    Dobar dan :slight_smile:

    Can you tell us a bit more what do you need help with, the steps Adam explained for switching caching are pretty straightforward and shouldn't be to complex to follow?

    I do see that Humminbird caching doesn't register caching being defined in wp-config.php file.
    You should access your site files via FTP or cPanel and navigate to WP root folder where you should see wp-config.php file.
    Make a backup of it and edit it, and add this line of code somewhere near the start of the file:
    define('WP_CACHE', true);
    It should look something like this:

    Before doing that make sure that in Settings > General you set "Cache Level" to Off.

    About Asset Optimization, there's nothing really technical here, it's more of a trial and error job.
    The thing is that each site is unique based on the theme and plugins that it uses so Asset Optimization setup is pretty much unique for each site.

    I have enabled Asset Optimization advanced mode for you so you can now go to Hummingbird > Asset Optimization and start tweaking your files there.
    You will see that each file has 4 options, if some are greyed out it means that your file is already optimized or your server is doing it so there's no need to do it again there and that's why the option is unavailable.
    Goal here is pretty much to have as many options enabled as possible, without affecting your site functionality.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.