Performance report 45%

My overall score is low, 45%. I've got smursh for my graphics.

The first option on the Hummingbird dashboard is Enable compression - score 32/100 - server. When I click enable compression I get 'config GZIP compression' not working - "could be server issue or a plugin". I've deactivated all non essential plugins, my overall score is the same. Do I need to contact my hosting company and ask them to have 'deflate module' enabled? Is there any more details I need to tell them.
Thanks Delia.

  • Nastia

    Hello Delia , hope you're doing well!

    I've tested your site with Google PageSpeed Insights and the current score is 63 / 100.

    There are few things that need to be improoved regarding Image Compressing. The images shown at the test results need to be resized to dimensions set in the WordPress default settings of your site. To resize images, go to Media > WP Smush, enable Resize original images option and add the suggested by the plugin dimensions:

    To reduce server response time install a caching plugin like WP Super Cache or Batcache.

    As for the Gzip Compression, would you please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Cheers,
    Nastia

  • Delia

    Nastia, Thanks for that. I'm half way through re smushing my images, then I'll enable 'resize original images option'. I've had a look at the plugin WP super cache and am prepared to have a go at setting it up, but would really appreciate some assistance if I have difficulty with the settings. I've granted 'support access' so you can have a look at the Gzip compression.
    Thanks again, Delia.

  • Nastia

    Hello Delia

    Hope you're doing well!

    Thank you for granting access. I've enabled GZIP Compression on your site from Hummingbird > GZIP Compressions. It does show that compression is deactivated for text/html type, though after running a performance report the Server Compression is ranked at 100%. This means that the text/html is already enabled on a server level.

    I see that you've already a cache plugin installed - W3 Total Cache, so there is no need to install WP Super Cache.

    The performance score now went from 45 to 87.

    What is left is to optimize two images and Remove render blocking resources.

    Remove render blocking resources can be fixed with Minification feature, though please make sure that the minification is not activated in W3 Total Cache. Activating Minification feature in both plugins might cause conflict on a site.

    If you choose to activate Minification within the Hummingbird plugin, please check after activation the front end, because not every CSS/JS file can be combined or minified. In case if something broken, for example, a Title is missing some styling, locate the theme's CSS file and play with a combination of Combine & Minify option till it's fixed.

    To remove render blocking resources move all JS files to a footer one by one, each time checking your front to make sure everything is well.

    Hope this helps!

    Cheers,
    Nastia

  • Delia

    Thanks for enabling GZIP Compression Nastia.

    Currently Minify is enabled on W3 total cache, so I'll leave Hummingbird as is. I don't go into the back end of my site, as I don't know code.

    In the W3 total cache menu under minify I see options under JS minify settings - before </head> (currently set to 'non blocking using async') and after <body> (currently set to 'default blocking'). Is there something I can/should amend here?

    Cheers,
    Delia.

  • Nastia

    Hello there Delia

    It's not totally safe to mess with JS minification, though you can play around with these settings to see which is best for your site.

    The most preferable choice is to set the Before </head>option to Default (blocking), which will instruct browser to stop rendering and load the Javascript files that are located before HTML </head> tag and run the code.

    Hope this helps!

    Cheers,
    Nastia