Performance Scan, Server score 7%

After having Gzip installed, upgraded from php 4x to 5.5 and having opache enabled.... my server is slower than ever!!! i hardly have anything done with building a site and Its so difficult to get anything done when the load time takes nearly a minute!!! what am i going to do now to increase server response time?

  • Tyler Postle
    • CGO

    Hey Bryan,

    It would be best to contact your web host for server response time issues. They should be able to improve it a lot from their end even. They also have access to all the necessary logs/monitoring to see why it's taking so long in the first place.

    If you grant support access for me than I can have a look at your system info and see if I can find anything there, but again this is a better question for your web host/system admin.

    You can grant support access via WPMU DEV > Support > Grant Support Access.

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I do see that in your performance report, another issue is render-blocking JavaScript and CSS. Hummingbird's Minification feature will help resolve that. We have a post written to explain how it helps since it can sometimes be a pretty tricky to setup correctly depending on your plugins and theme: https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    That guide will help walk you through it :slight_smile:

    If you have further questions on that then let us know.

    Look forward to hearing back.

    Cheers,
    Tyler

    • Bryan
      • Design Lord, Child of Thor

      Hello Tyler,

      Thank you for the helpful information;

      Per Nithin's advice on the subject matter in a different ticket ... I contacted the hosting provider to have Mod deflate enabled opcache enabled and php upgraded. but by doing so the times have not improved but have gotten worse...

      When I communicated with ipage tech support its usually the run around as to why it could be happening... Hence i decided to make a new ticket dedicated on this matter.

      Ill contact them again to find out why.
      I also have enabled access.

      Kindly
      Bryan

  • Bryan
    • Design Lord, Child of Thor

    doing some research on Pingdom:
    GRADE SUGGESTION
    C71 Specify a cache validator
    The following resources are missing a cache validator. Resources that do not specify a cache validator cannot be refreshed efficiently. Specify a Last-Modified or ETag header to enable cache validation for the following resources:
    http://automatingbusinesses.com/wp-admin/admin-ajax.php?action=upfront_load_grid
    http://automatingbusinesses.com/wp-admin/admin- ... Btype%5D=archive&layout_post_id&template_post_id

  • Tyler Postle
    • CGO

    Hey Bryan,

    Sorry for such a delay here. Thanks for your patience.

    I see your site is still loading quite slow. Do you mind re-granting support access and also sending in your FTP? That will help speed up troubleshooting :slight_smile:

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you grant support access then no need to send in wp-admin

    I still think it is likely something server side if it's the server response time; however, we can at least help narrow it down if that is the case so you can provide more evidence to them :slight_smile:

    Talk to you soon.

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Bryan,

    No problem, a big part of the issue appears to be your plugins. When I test your site with all plugins deactivated, it loads much faster.

    You can try this by temporarily re-naming the "plugins" folder and then navigating around your site. You will see that it responds much quicker.

    The best way to narrow down which plugin is causing the problem is by creating a secon folder in your /wp-content/ named something like "plugins-deactive" and then dragging your active plugins into that folder one by one and testing out your page load speed after each one - once the load speed is noticeable quicker then you will see which one was causing the problem.

    This does involve plugins being deactivated for a little bit of time on your site, so you may want to do it on a staging site if you have one.

    You can also use the P3 plugin to test your plugin's impact but keep in mind it hasn't been updated in over 2 years: https://en-ca.wordpress.org/plugins/p3-profiler/

    Many people still use it, but it's results may not be 100% accurate.

    Let us know if you still need any further assistance after that :slight_smile:

    Cheers,
    Tyler

    PS. One last step you can take is to ask your host about the server response time, see if there is anything they can do from their end. Although, I do think the plugin problem will make the biggest as you'll see when you try the site speed with all plugins deactive.

    • Bryan
      • Design Lord, Child of Thor

      Greetings Tyler,

      Hope you are well and I would like to thank you for providing me with the helpful information and advice.
      once I have the time this evening I will check to find which plugin it might be. I also have received a message from the tech support with the same conclusion.

      Ill report back shortly.
      Regard
      Bryan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.