Performance test cannot run as this is local installation error in Hummingbird

I cannot run performance test on my site. It shows “The performance test didn’t return any results. This probably means you’re on a local website (which we can’t scan) or something went wrong trying to access WPMU DEV. Try again and if this error continues to appear please open a ticket with our support heroes”

  • albertpr9
    • Flash Drive

    Hi Ash,

    I spent maybe 30 to 40 mintues with support yesteryday regarding Asset Optimization, that for me, when I click on it, it gets stuck at 0%…

    We never spoke about a performance test. But I’m not sure if this the same thing.

    But anyways, I tried it again now, and it’s still stuck at 0%. I can’t activate Asset Optimization. Would you be able to take a look at that?

    Thanks Ash!

  • Nithin
    • Support Wizard

    Hi albertpr9,

    Sorry for the delay in getting back to you, we tested further in Asset Optimization, and could notice the issue with Asset Optimization not starting, and stuck with 0%. Just to double check whether the theme, or existing plugins are causing any conflict, I enabled debug mode with all the plugins disabled, but unfortunately it didn’t give much clue.

    I was able to notice 502 error in the browser console when Hummingbird Asset Optimization was enabled.

    The websites server resources do look good, so that shouldn’t be causing the 502 error in general, could you please check with your hosting provider, and see whether they are able to pin point any specific query, or action causing the 502 error, when Asset Optimization is enabled?

    Also, if you could also get the server error logs from the hosting provider, it would be helpful.

    Other than that, I was able to notice the following error in the debug log, which seems to be related to WPML plugin:

    WordPress database error Duplicate entry '24871-en-us' for key 'trid_lang' for the query

    However it’s pretty tough to say what exact is causing without checking the server logs. Please do let us know what your hosting provider has to say about the 502 error, so that we could have a better idea, regarding the issue.

    Looking forward to you reply, have a nice day ahead. :slight_smile:

    Regards,

    Nithin

  • albertpr9
    • Flash Drive

    Hi Nithen,

    I’ve checked with WPENGINE and below is their reply:

    ok, so it looks like it was the long process killer hitting that Humming Bird Pro. It is taking more then 60 seconds to complete thus our long process killer is killing it.

    Also I checked the server error logs, and they are empty. No errors on the site.

    I guess it’s just taking over 60 seconds to load, so the process is being killed.

    Any ideas of what I could do to get this running?

    Thanks.

  • Ash
    • WordPress Hacker

    Hello albertpr9

    Do you have lots of asset files on your site? I am asking because, we have other members running their site on WPE using HB asset optimization without any issue.

    Also, would you please run a conflict test? It may happen that another plugin is interfering the process. Please deactivate all plugins except this one and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1

    Let us know how it goes. Have a nice day!

    Cheers,

    Ash

  • Ash
    • WordPress Hacker

    Hello albertpr9

    Do you have lots of asset files on your site? I am asking because, we have other members running their site on WPE using HB asset optimization without any issue.

    Also, would you please run a conflict test? It may happen that another plugin is interfering the process. Please deactivate all plugins except this one and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1

    Let us know how it goes. Have a nice day!

    Cheers,

    Ash

  • Luís
    • Support

    Hi albertpr9 ,

    Hope you’re doing well today sorry for the extreme delay in the reply.

    I flagged the SLS team (our code experts :slight_smile: ) to investigate further why the process is taking so long.

    Since this team deals with more advanced threads it may take them longer to reply.

    Cheers, Luís

  • Konstantinos Xenos
    • Rubber Duck Debugger

    albertpr9 ,

    We’re in the process of changing some things towards better regarding the Performance Tests so there will be updates in the upcoming releases on this section that should fix hiccups like this.

    I’ve run the process more than 1 times and finally it yielded some results so this seems to be something between caching + the limits that WPE mentioned.

    Since the process is on steps and it keeps the results if you run the test enough times at some point it will bring back results as it has actually managed to finish it’s whole process ( that’s what happened on your installation during my tests ).

    Unfortunately it’s not an easy task to ‘patch’ this on your end as the changes are quite a lot so you’ll have to wait for our newer releases and make sure to update!

    As an extra note that is really interesting coming from WP Engine, the general rule of thumb and used as a standard is to have a minimum of 120s for an execution time. I can’t be sure why WPE decided to cut that even further down, but maybe you can ask them to raise it for you as well.

    Tell me if you need any fruther information or help so we can assist and sorry for this inconvenience.

    Regards,

    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.