Permalink isse in WPMU main site

Om my main site in a WPMU network, I decided to change my /blog/ to /fast-track/ and have made that change in my permalinks settings for the site (Network Admin > Sites > [choose site] > Edit > Settings > Permalink Structure to /fast-track/%postname%/.

When I go to I see my two blog posts. The link to read more (and the title link) both point to, but that 404's. When I go to I can see my post in its entirety.

This is weird! Changing the permalinks should put all blog posts at /fast-track/. And yes, I Purged the Siteground cache, browser refresh, etc.

How can I fix this so that all my posts are in /fast-track/ ?


  • Denitsa

    Hello Larry Levenson,
    I hope you're having a beautiful day!

    You could remove the /blog slug altogether, but I'm not aware of any foolproof way to change that, so I'm advising here solely on limited experience on my sandbox site.

    Basically, you'd need to do what you said you've already done and then go to Settings -> Permalinks for your subsite and add /fast-track to your permalink structure.

    Here are the steps just to be sure:
    1) Go to Network Admin -> Sites and Edit your blog.

    2) Then, go to the Settings tab and scroll down to Permalink Structure
    3) Just remove the/blog part (change it with /fast-track in your case).

    4) For that subsite, open Settings -> Permalinks and re-save that.

    Now should actually not be accessible, but you should be able to open posts at fast-track/permalink-structure/post-name and they should be listed on your main site (not under /fast-track).

    Please make sure to make a backup before tweaking permalinks though.

    If you've already tried that, can you please grant support access from the dashboard plugin so we can take a closer look?
    This could be done via Dashboard - WPMU DEV -> Support -> Support Access -> Grant Access or by following this guide here:

    Let me know once you've done that!


  • Adam Czajczyk

    Hello Larry!

    The way to change that /blog/ slug part to anything else and get all the posts slugs updated automatically would be as follows:

    1. in order to revert changes go to " (Network Admin > Sites > [choose site] > Edit > Settings > Permalink Structure" and replace /fast-track/ there with /blog/ again as it was.

    2. Go to the dashboard of your main site (site #1) and click on "Settings -> Permalinks" and re-save them using "Post name" option and then again using "Custom Structure" (with the default setting that it will automatically set up).

    That should bring back default configuration.

    3. On the same page switch permalinks settings to "Plain" and save them
    4. Then go back to "(Network Admin > Sites > [choose site] > Edit > Settings > Permalink Structure" and set it to "/fast-track/%postname%/"
    5. Then go to the Permalinks settings in main site's dashboard again and switch them back from "Plain" to "Custom Structure".

    That should as a result make your site use /fast-track/ as slug instead of /blog/ and update all post links. The crucial steps here are to first swtich permalinks structure on site to "plain", then make a change in "Settings" and then switch it back.

    Kind regards,