Permission error when attempting to update dev dashboard

AFter a bright red uninformative fail banner that does not give any useful info on what the problem was just saying "maybe permission error" and the dashboard plugin update did not confirm install. Clicking on the admin -> wpmudev the plugin no longer shows needing update and shows 4.1 version. Not sure it is working properly since when I go to the hub the first thing i see wrong is that no plugin is listed with versions. Not sure if anything else is broken. you have access to communitycomments.com.