Permissions Issues on network – users disappearing, plug-in discrepancy?

I am trying to use a bundle of plugins from WPMUdev.

Kimberly has helped me get Pro Sites partially up and running – however, in the last week, since installing Easy Blogging and New Blog Templates to work in conjunction with Pro Sites, I must have missed a setting or three along the way.

Logged in as Super Admin, on the Network Admin user list, I can see all of the users and the sites that are subscribed to. However, logging in to my main site ( to look at the users solely on it, several of the names disappear, even though they are on the Network Admin list – and indicated as being part of that site.

If one of those users tries to log in to the main site, they can get in, but they have no permissions any longer. They don’t have access to the dashboard or to post new blogs. Several of these users should be Authors, but have no permissions and receive the error stating so when they try to access the dashboard.

As the Super Admin, when I try to ‘add’ the user to the specific site, I am told the user already exists on that site.

In a search for these users, they don’t show up. They don’t show up in the list, either.

I’m starting to get frustrated.

I disabled the Pro Sites this morning, and the ability for users to create a new site. I’m hoping to very soon get all the bugs worked out so that my time is spent promoting and maintaining the site instead of trouble-shooting while building. It’s definitely not my forte.


  • Mason
    • DEV MAN’s Sidekick

    Hiya @jloweezy,

    Sorry to hear you’re having trouble here. You mentioned that the users disappeared from the main site listing and that they “have no permissions any longer”.

    So does this mean they previously DID appear in the list and DID have some kind of permission?

    If so, that would mean something has started to block them. What other plugins are you running on the site? Anything user role related?

    Did disabling Pro Sites and user creation help in some way?

    I can definitely understand your frustration. Kinda like trying to fix your own car when all you want to do is get your groceries! :slight_smile:

    Let me know the answers to the above and we’ll see if we can’t track this down.


  • jloweezy
    • Site Builder, Child of Zeus

    Hi Mason. Thanks for addressing this – I hope to get it resolved soon, and I appreciate the attention. :slight_smile:

    Yes, they did previously show up in the list, and they have previously had permission to make posts with Author status. One of the missing profiles is my personal profile, which is how I discovered the issue in the first place.

    The changes I made recently were with Pro Sites, Easy Blogging, and New Blogging Template. I disabled the Pro Sites, and changed the settings for new users to be able to register, but not create a site, and I am still having the problem.

    Something slightly interesting is that it seems to have happened to the accounts that tried to create new sites. I used my personal profile to try out the Create Site link, and once I made it past the screen that says you have successfully created your new site, now log in to it using your credentials….

    Then I would try to log in and would get told that I don’t have permissions to access that site.

    When going to the new site, it would only list the Super Admin as a user for that site.

    And as quirky as it is, these are the similarities between the issues that I’m having right now. Any help at all?


  • Mason
    • DEV MAN’s Sidekick

    Hiya Janet,

    This is truly bizarre (I know, not helpful).

    Pro Sites, Easy Blogging, and New Blot Templates don’t make changes to actual user roles which is where I’ve encountered this type of issue previously

    Have you used anything like Members or User Role Editor? When you go to edit a person’s profile, what user roles show up?

    This sounds like a database issue. Something’s been corrupted and causing this happen. A database repair may do the trick or you may need to visit the contents and update manually.

    I’d start by checking the wp_#_options tables for an option name of “wp_#_user_roles” (the # sign refers to the number of the blog ID).

    Check to ensure the default roles exist (Administrator, Editor, Contributor, Subscriber). If not you may need replace that with the correct data.

    Let us know if you need help with that – and sorry it’s not immediately obvious what to do here :disappointed: We’ll get there.


  • aecnu
    • WP Unicorn

    Greetings Janet,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.