Anti-Spam component of Comment Spam Pack.

I've been seeing errors in my Apache server log such as:

Call to undefined function site_url() in ... mu-plugins/custom_anti_spam.php on line 264

This apparently occurs on a URL such as:
wp-content/mu-plugins/custom_anti_spam.php
without any query args.

I noticed that the version of Peter's Custom Anti-Spam plugin is very old. In the Comment Spam Pack it is at version 2.84 from 2007. The latest version is 3.1.4 from Aug 2, 2010:
http://www.theblog.ca/anti-spam-history

I checked the latest version and noted that there is no call to site_url().

Can the Comment Spack Pack be updated?

Thanks,

Scott

  • Mason
    • DEV MAN’s Sidekick

    Hiya Scott,

    Apologies for the delayed response. I'll see if Ulrich is available to help you get this sorted. I know he's working on an update to this plugin at the moment and this may be one of the things he's addressing. Also, thanks for the detailed feedback and results from your searching. It definitely is a help!

    Ulrich, got any ideas?

    thanks!

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Scott,

    Can you let me know if you're still having this issue?

    We have a new developer on this project who I can forward this to. I'll mark it as resolved just in case it's all okay now.

    If not, just reply below and re-open and we'll get ya sorted.

    Phil

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.