PHP 5.2 or 5.3?

Which do you recommend on a basic Linux CentOS install? I've heard 5.2 is more reliable than 5.3. Is that still true?

Thanks!