PHP Compatibility Check says deprecated code in plugin

I am wanting to upgrade my PHP on my site to 7.3, and I ran a check through PHP Compatability Checker and an error came back for Hummingbird Pro:
FILE: /wp-content/plugins/wp-hummingbird/core/modules/class-advanced.php
————————————————————————————————————–
FOUND 1 ERROR AFFECTING 1 LINE
————————————————————————————————————–
530 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
————————————————————————————————————–
How can I fix this so I can update my PHP and not run into issues?

  • Ash
    • WordPress Hacker

    Hello there

    Still, lots of websites have been running on older version of php, so we maintain the backward compatibility. The error you are seeing is basically a false positive because of that backward compatibility. This plugin works fine with latest version of php as well as older version of php. So, you need not to worry about that.

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.