PHP Error on every WPMU and WPML plugin

I have had a recurring error since installing WPMU and WPML plugins and recently using simple_error_handler tracked this down to the following error:

STRICT(2048), Non-static method Wdca_AdminPages::serve() should not be called statically

This is apparently inherent on every plugin. Is there a single re-useable code snippit that's called or is this going to require wholesale modification of all the plugins. I am trying to get the WP site to run optimally and clearing every error sytematically. i can't get rid of this one using your plugins. As I've paid for the Pro service, I would hope they would not have these sorts of issues especially after this long a time of deprecation.

  • Vaughan

    Hi @len,

    These are pretty STRICT errors and are dependant on your PHP version.

    Unfortunately we have to make sure our plugins support the same version of PHP that wordpress supports, currently 5.2.4, so to fix all these STRICT mode errors would likely mean rewriting a lot of plugins which could then break compatibility with older PHP versions.

    You shouldn't need to worry about STRICT standards anyway, Disable strict notice error reports, so that they don't bother you.

    Hope this helps

    • Len

      We run a secure website, so disabling strict is not an option for us. PHP 5.3.0 was released in 2009, PHP 5.5.0 in 2013. They’ve both outlived their official support by the PHP project for quite a while now. The security support for 5.6 is only available until the end of 2018.
      PHP Version 7.0 active supports at the end of this year (2017) with security support ending before the 5.6 branch next year (2018)
      Is it not about time that the plugins were brought up to a level of at least a supported and secure version of PHP? It may encourage your plugin developers to write secure plugins.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.