PHP Fatal error: Uncaught Error: Call to undefined function submit_button()

Hello there,

i've an issue with automatic sync from WPMUDEV. Got error 500 when trying to auto-setup defender from WPMUDEV hub ... i'm not sure from where it comes, and on Google there is no good answer.
My WordPress installation is at its basic, fresh install. I've set what required to auto-install plugins by php7 libssh2 from the admin panel. WPMU Dashboard was auto successfully installed via Sync feature from WPMUDEV Hub. WordPress version is 4.8.1. I'm my own web provider (dedicated server) and use Apache2 with PHP7.0 (with userdir mod).

Here the error:
PHP Fatal error: Uncaught Error: Call to undefined function submit_button() in /home/MYUSER/public_html/WP/wp-admin/includes/file.php:1279\nStack trace:\n#0 /home/MYUSER/public_html/WP/wp-admin/includes/class-wp-upgrader-skin.php(95): request_filesystem_credentials('', 'ftpext', false, '/home/MYUSER...', Array, false)\n#1 /home/MYUSER/public_html/WP/wp-admin/includes/class-automatic-upgrader-skin.php(47): WP_Upgrader_Skin->request_filesystem_credentials(false, '/home/MYUSER...', false)\n#2 /home/MYUSER/public_html/WP/wp-admin/includes/class-wp-upgrader.php(196): Automatic_Upgrader_Skin->request_filesystem_credentials(false, '/home/MYUSER...', false)\n#3 /home/MYUSER/public_html/WP/wp-admin/includes/class-wp-upgrader.php(691): WP_Upgrader->fs_connect(Array)\n#4 /home/MYUSER/public_html/WP/wp-admin/includes/class-plugin-upgrader.php(110): WP_Upgrader->run(Array)\n#5 /home/MYUSER/public_html/WP/wp-content/plugins/wpmudev-up in /home/MYUSER/public_html/WP/wp-admin/includes/file.php on line 1279, referer: http://www.mywebsite.ca/wp-load.php?wpmudev-hub=5995...

Thank you so mutch for your support :slight_smile:.

  • o_be_one
    • WPMU DEV Initiate

    I did the setup from Admin panel in my WP ... It worked. After i've clicked activate from the WPMU Dashboard in WP Admin panel and got OK 200 marked as error with endless loading lightbox (but the plugin was activated by this way ...):

  • Predrag Dubajic
    • Support

    Hey o_be_one,

    Hope you're doing well :slight_smile:

    I must say that I didn't see a report for this fatal error before and would like to investigate this further on your site.
    Would you mind allowing support access so we can check it out?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • o_be_one
    • WPMU DEV Initiate

    Hello Predrag,

    Thanks a lot for your support.

    Unfortunatly i've continued my work on it, but if required you are allowed to remove defender and put it back, no problem. Anything can help you, do it, i haven't worked a lot on it since yesterday so it's easy to set things again.

    If you can't reproduce the issue anyway, i've a copy of this installation for an other website from when i had not installed WPMUDev Dashboard, so it will probably reproduce.

    Thank you!

  • Dimitris
    • Support Star

    Hello there o_be_one,

    hope you're doing good and don't mind me chim in here! :slight_smile:

    The error that's strange for us is the one reported on the thread description, as the "status OK:200" is a known glitch that doesn't affect anything (it's actually a success message that shouldn't be displayed at all).

    As for the fatal error though, was that when you were trying to install Defender via its product page here? https://premium.wpmudev.org/project/wp-defender/

    Or maybe through the Getting Started page here?
    https://premium.wpmudev.org/hub/getting-started/

    Please advise so we could try to replicate this!
    Warm regards,
    Dimitris

  • Adam Czajczyk
    • Support Gorilla

    Hello o_be_one,

    Could you please try one more fix? Please add following line to the "wp-config.php" file of your site:

    define( 'FS_METHOD', 'direct' );

    Make sure that it's added above the "/* That's all, stop editing... */" line and after that, please check both issues (both install from WPMU DEV The Hub and activation from inside the WPMU DEV Dashboard plugin).

    Let me know please if that helped (in case it didn't work at all, remove the line again)!

    Best regards,
    Adam

  • o_be_one
    • WPMU DEV Initiate

    I think it looks like this one already present in my wp-config (for auto-installer using SSH method instead of FTP):

    /** Patch to fix issue with SSH auto installation */
    if(is_admin()) {
        add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
        define( 'FS_CHMOD_DIR', 0751 );
    }
  • Predrag Dubajic
    • Support

    Hi o_be_one,

    Can you tell me what exactly happened when you tried to install Defender from HUB, after clicking on installation button did you get redirected to your site and that's when the 200 message was shown?

    Installation process of Defender should actually happen directly from HUB, you should be able to install and activate the plugin directly from there, without accessing your site admin section at all.

    Could you try this on your other installation that you mentioned and see if the same thing happens there?

    Best regards,
    Predrag

  • o_be_one
    • WPMU DEV Initiate

    Hello Predrag,

    as you can read in the first post of this topic, i've tried to install Defender from Hub.
    1- clicked Hub
    2- clicked Security tab
    3- clicked Install Defender
    4- got error : not possible to install (500 error)
    5- gone to my web logs and seen this message

    The second part, about the 200 OK in red, was in WP admin dashboard in WPMU Dashboard > Plugin:
    1- clicked WPMU Dashboard in WP Admin
    2- clicked Plugins
    3- clicked Install Defender
    4- clicked Activate when Defender was successfuly installed and go error 200 OK

    I'll try on the other installation, probably it will happend again cause it's a copy of the first one. I'll let you know asap.

  • Predrag Dubajic
    • Support

    Hi o_be_one,

    Thanks for the additional info, I just wanted to make sure that I'm following the same steps and that I'm not missing anything here.

    Did you get the results from the other site?

    If they are not hosted on the same server it's unlikely that you will get same error as it's most likely server related, but if you do we might be dealing with plugin conflict here.

    Can you tell me if the above posted debug is all of it or there's some more?
    If there is, can you save the log file as .txt file and attach it here so we can check it out?

    Best regards,
    Predrag

  • o_be_one
    • WPMU DEV Initiate

    Hello Predrag Dubajic,

    Ok i've tried on the other website:
    - installed WPMU Dashboard by Hub using "Sync my website" (Success)
    - after this step, it offers me to install Defender, i've clicked "Install"

    All are hosted on the same server, and use the same settings (permissions etc).
    Posted debug is all what i got.

    It's quite the same error log as before, but not the same step. I let it like that, and open the support access so you can check it (defender was never installed on this one). I'll not work on it for some weeks so you can do whatever you want to help this ticket. In the support grant i've added full error logs informations and provided a link to get access and error logs for both websites as support access comment. Also i've updated support access comment on the first website and extended the grant.

    Thank you !

    -- Meddy

  • Predrag Dubajic
    • Support

    Hi Meddy,

    Thanks for the additional info, I'm currently chatting with our devs about this and we're trying to figure out what could be causing this for you.

    Can you tell me if the issue is specific only with Defender or you had issues with our other products as well?

    Also, could you tell me if you wp-config.php file has FTP credentials defined inside?

    Best regards,
    Predrag

  • o_be_one
    • WPMU DEV Initiate

    Hello Predrag,

    I've just tryed to install WPMU Dashboard, Defender and Upfrond. I had only issue with Defender (Upfront was OK).

    My wp-config had SSH credentials, not FTP ; so it has an address, a login and ssh keys.

    Have a good day!

  • Ivan
    • Developer

    Hi o_be_one !

    I tested this situation on my new site and it works fine.

    If you provide me with additional login credentials, I can look into it more.

    https://premium.wpmudev.org/contact/#i-have-a-different-question
    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Ivan Svyrskyi"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Wpmudev login details (that we can try to replicate this issue)
    Wpmudev username
    Wpmudev password

    - FTP/SFTP credentials ( that we can see your wp-config settings )
    host
    username
    password
    (and port if required)

    Note: Don't send any credentials via this forum because it's public forum.

    Best regards,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.