php file errors while installing the appointment plugin.

There happened errors in appointment php file on my site.
[Appointments+] Either php curl is not installed or HTTPS wrappers are not enabled. Login with Google+ will not work.
Please refer to http://screencast-o-matic.com/watch/cDn2oc1cV3

  • Sajid

    Hi @skaye234,

    Hope you are doing good today :slight_smile:

    [Appointments+] Either php curl is not installed or HTTPS wrappers are not enabled. Login with Google+ will not work.

    This means either curl extension is not loaded on your server or your server blocked HTTPS outbound request. That are required to connect with third party services likes Google Calendar.

    If you don't need to integrate Appointments + with google calendar then you can ignore this message. Otherwise contact your host to enable curl and HTTPS wrappers.

    I can not replicate the issue you reported in screencast. However, they are seems to be just warnings and notices for developers only. As long as appointments are working fine (I confirmed that they are working on your website) you can simply hide the warnings by adding following code in wp-config.php file before the line that says stop editing.

    define('WP_DEBUG', false);

    If the above define already exists in wp-config.php file then just change the value from true to false.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • sukhan

    1) If you don't need to integrate Appointments + with google calendar then you can ignore this message. Otherwise contact your host to enable curl and HTTPS wrappers.
    -> I have a question about the above reply. What is different between integration with google calender and not integrating with it. I wonder if the appointments + can function well without google calender.

    2) you can simply hide the warnings by adding following code in wp-config.php file before the line that says stop editing.
    - The code in the wp-config php of my site is the same you mentioned
    Please refer to the code below

    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    add_filter( 'auto_update_plugin', '__return_true' );
    add_filter( 'auto_update_theme', '__return_true' );

  • Vaughan

    Hi sukhan,

    #1 Yes, Appointments+ is designed to work without google calendar, using google calendar is just a bonus for those that want to use it, but it isn't actually necessary for the plugin to work.

    #2

    Can you try replacing the line that says

    define('WP_DEBUG', false);

    Replace with the following;

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);

    Now any errors will be logged to a file called debug.log, located in your /wp-content folder. This is better than having them printed to screen as the actual debug notices can actually cause issues too.

    The above should prevent errors displaying on the screen.

    Also, please remove the following lines from your wp-config.php

    I don't know who or why they were added there, but they should not be there, you shouldn't be using any filters in wp-config.php, they will cause issues.

    add_filter( 'auto_update_plugin', '__return_true' );
    add_filter( 'auto_update_theme', '__return_true' );

    If you wish to use those filters, then they should be added to your theme functions.php or as a mu-plugin.

    Hope this helps

  • sukhan

    Hi there !

    Do you not understand your explanation. So I need to check whether my understanding is right or not.

    Can you try replacing the line that says
    1) define('WP_DEBUG', false);

    Replace with the following;
    2) define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false); >>>

    Q1) You mean that 1)code have to be change into 2) codes ??

    3) add_filter( 'auto_update_plugin', '__return_true' );
    add_filter( 'auto_update_theme', '__return_true' );

    Q2) Should I delete 3) codes in wp-config.php. What if I remove the code...

  • Vaughan

    Hi,

    Yes.

    Find the line in wp-config.php

    define('WP_DEBUG', false);

    Replace it with the following lines so it looks like;

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);

    So basicly, you are adding 2 lines below the WP_DEBUG line.

    #3 Delete the following lines completely.

    add_filter( 'auto_update_plugin', '__return_true' );
    add_filter( 'auto_update_theme', '__return_true' );

    Instead, place them in your theme functions.php

    Hope this helps

  • sukhan

    Hi there!
    I did as your instruction, but there are still errors when I try to arrange the schedule.
    I think your appointment system is making me complicated. so I may not use it continually...

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  • Sajid

    Hi @skaye234,

    Hope you are doing good today :slight_smile:

    I am sorry to hear its not working for you as expected and the code given by Vaughan did not worked.

    Would you please replace code below provided by Vaughan:

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);

    With this one:

    define('WP_DEBUG', false);
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);

    It seems there is a plugin or themes that is forcing to display the warnings and errors message. This will ensure to not display unnecessary warnings and notices.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

  • Panos

    Hello @skaye234,

    Sorry to hear that you re still having troubles with this issue. I would be pleased to have a look at your files, but first you need to grant us Support Access so we can check the admin panel.

    Also we would require ftp access in order to edit your wp-config.php file.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select “?I have a different question?" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:Subject: "Attn: Panos Lyrakis”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Thanks!
    Panos

  • Panos

    Hello @skaye234,
    Hope you are having a great weekend!

    Thank you for sending your ftp credentials! I noticed that although you had pasted the code posted from Vaughan and Sajid, there were some invalid characters included, probably added by your editor.

    I assume that might be the reason that the code was not working for you, so I would like you to confirm if the messages are gone now, since I removed them.

    Thanks!
    Panos

  • Panos

    Hello @skaye234,

    Apologies for not being clear. I was referring to the messages you describe here http://screencast-o-matic.com/watch/cDn2oc1cV3.

    In one of your previous messages in this thread you posted

    Please get the pressure and waste my time doing that~

    Let me ask you to stand in for me to check the code on my site ~

    That reply of yours was referring to placing some code in your wp-config.php file, as my colleagues suggested, in order to hide some Warning messages you were seeing in your screen.

    I had a look at your wp-config.php file and noticed that although the code was pasted there, the editor must have added some invalid characters. Of what I understood you were still seeing these Warning messages and the reason for that might be these invalid characters.

    So I was wondering if you are still seeing these Warning messages now that the code has been corrected?

    Thanks,
    Panos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.