PHP Incompatibility

I ran a scan and it came up with the Dashboard not being compatible with PHP 7.1, which is what the hosting is running on.

  • Predrag Dubajic

    Hi Marker,

    These kinds of scans do not actually check if the plugin is working with the latest PHP version, it will only check if there's a code in there that was written to work with certain PHP versions.
    Dashboard plugin includes both the code for old and new PHP versions and will use the one depending on PHP version used on your site.
    So if you have PHP 7+ it will use code for that and will ignore the code for old PHP versions, and this is unfortunately not something those PHP checkers can catch and thus show the plugin as incompatible with newer PHP versions.

    Hope this clears things up :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.