PHP MySQL library version differs from MySQL server version

Good Afternoon

I need to back up my databases before I perform a much needed update. However when I access my phpMyAdmin I see the following warning:

“your PHP MySQL library version 5.5.47 differs from your MySQL server version 5.6.28. This may cause unpredictable behavior”

How do I make sure they are both the same? Will this happen automatically once I perform the updates that are needed?

thanks for your help

Brenda