PHP Notice: register_sidebar_widget in wordpress 3.8.1

[08-Feb-2014 16:56:18 UTC] PHP Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/hostings/public_html/wp-includes/functions.php on line 2908
[08-Feb-2014 16:56:18 UTC] PHP Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/hostings/public_html/wp-includes/functions.php on line 2908
[08-Feb-2014 16:56:18 UTC] PHP Notice: ob_end_flush() [ref.outcontrol]: failed to delete buffer zlib output compression in /home/hostings/public_html/wp-includes/functions.php on line 2773

  • cry1978
    • The Incredible Code Injector

    I am using default themes of wordpress first install?

    this happens with wordpress first install using just the default wordpress template and then squeezing in little by little wpmu dev plugins. I have tracked down every plugin creating problems, a lot are deprecated functions and a lot have undefined variables or constants (that can't be fixed by filling in details in the input fields of the admin pages) within each plugin and I mapped out that it is related to the plugins them self and buddypress.

    Yea, I do need to brush up on my php to find out how to fix it if the developer can't?

  • cry1978
    • The Incredible Code Injector

    Yes I kinow that notices and warnings are nothing to worry about unless

    Why am I seeing PHP errors and what do they mean?
    BPS is alerting you that php errors have occurred on your website and logging these errors. BPS is not generating these php errors. In general php errors are a natural thing that will occur on every website intermittently. What is not natural or normal is to see the same php error happening repetitively and continuously. Logged PHP errors should be considered as helpful. PHP errors very accurately display exactly where coding issues or problems are occurring on your website that need to be either looked into or fixed. Fatal php errors need your immediate attention and should be fixed right away.

    cited
    http://www.ait-pro.com/aitpro-blog/3576/bulletproof-security-pro/custom-php-ini-faq/

    The company above is the best company I found yet and I would recommend them.

  • cry1978
    • The Incredible Code Injector

    I forgot to say that yes I do see the same php error happening repetitively and continuously on every faulty plugin, there is about 25 or so plugins doing this, all name the plugins causing problems after my doc apt today. This problem is causing web hosting memory resource problems that will get your websites/domains shutdown by some hosting companies or just suspended.

  • cry1978
    • The Incredible Code Injector

    The plugins are:

    ad-sharing

    add-new-users

    advanced theme switcher

    bp group email

    comments plus

    contact form

    custom ads

    custom google search

    directory

    events and bookings

    google analytics async

    login redirect

    logout redirect

    pay per view

    protect selected content

    qa

    scheduled content

    signup code

    simple ads

    simple sitemaps

    tips

    user activity

    users widget

    wiki

    wpmu dev facebook

    wpmu dev seo

    youtube videos widget

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.