PHP version and Google calendar

Hello,
I use PHP Version 5.3.28. When click on "Test Connection" or "Check Requirements" (in Google Calendar section) it gives "[Appointments+] Google PHP API Client requires at least PHP 5.3". I can't test and start to use it. What is wrong here? Thank you.