PHP Warning

I receive the following warning:
PHP Warning: mysql_set_charset() expects parameter 2 to be resource, boolean given in /home/klixmed/public_html/wp-includes/wp-db.php on line 553,

This prevents me from adding posts or plugins and appears on every page. I have read the other threads related to this topic, and have suppressed the warning however my error logs are full of thousands of occurrences of this error. I was just wondering if anyone has found a solution to fix this as it will help me sleep better at night knowing that everything is in proper order.