PHP warning related to Upfront framework

I am getting a lot of PHP warnings related to the Upfront framework. There warning is "PHP Warning: substr() expects parameter 1 to be string, array given in /home/doulaboo/public_html/wp-includes/functions.php on line 1679". That line of code relates to the wp_normalize_path function.

I have searched all of my theme and plugin files, and the only time that function is called is in three Upfront files (see attached search results listing.)

Can you help me sort this out? The error was showing on my sites, and has been indexed by search engines as part of the content. I hid it for now, but my site error log is huge because of this and is affecting performance. I'd prefer not to have to switch themes, but I need this issue to go away.