PHP7 Compatibility for wpmuDEV Plugins Since 2016 there has been errors and warnings

PHP7 Compatibility for wpmuDEV Plugins Since 2016 there has been errors and warnings that have not been fixed or could be new issues that are not fixed.
this is what I found using PHP Compatibility Checker by wpengine

Membership 2 Pro - Warnings: 2
FILE: /home/XXXXXX/public_html/wp-content/plugins/membership/lib/stripe-php/lib/Stripe/Object.php
------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
------------------------------------------------------------------------------------------------------------------------------------------------------------
 239 | WARNING | Method name "M2_Stripe_Object::__toJSON" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
 253 | WARNING | Method name "M2_Stripe_Object::__toArray" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
------------------------------------------------------------------------------------------------------------------------------------------------------------
WPMU DEV Dashboard - Warnings: 4 Errors: 1
FILE: /home/XXXXXX/public_html/wp-content/plugins/wpmudev-updates/template/support-system.php
----------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 1 ERROR AND 4 WARNINGS AFFECTING 5 LINES
----------------------------------------------------------------------------------------------------------------------------------------------------
  77 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
 313 | WARNING | Function name "__render_list" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
 334 | WARNING | Function name "__error_reporting" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
 376 | WARNING | Function name "__value_format" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
 390 | WARNING | Function name "__const_format" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
----------------------------------------------------------------------------------------------------------------------------------------------------
  • HamRadioDude

    Found some more:

    Ultimate Facebook
    
    FILE: /home/XXXXXX/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_widget_albums.php
    -----------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------
     10 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    -----------------------------------------------------------------------------------------------------
    
    FILE: /home/XXXXXX/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_widget_likebox.php
    ------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------
     8 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ------------------------------------------------------------------------------------------------------
    
    FILE: /home/XXXXXX/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_widget_events.php
    -----------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------
     9 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    -----------------------------------------------------------------------------------------------------
    
    FILE: /home/XXXXXX/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_widget_connect.php
    ------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------
     7 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ------------------------------------------------------------------------------------------------------
    
    FILE: /home/XXXXXX/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_widget_recent_comments.php
    --------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    --------------------------------------------------------------------------------------------------------------
     8 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    --------------------------------------------------------------------------------------------------------------
    Rebranded Meta Widget
    
    FILE: /home/aresnyc/public_html/wp-content/plugins/rebranded-meta-widget/rebranded-meta-widget.php
    --------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    --------------------------------------------------------------------------------------------------
     58 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    --------------------------------------------------------------------------------------------------
  • Ivan

    HI HamRadioDude !

    Regarding Membership 2 Pro - it seems, these warnings don't break working of plugins. Also, as you can see, this part of the code is not our code, it's a library of Stripe and we will change it in future.

    Regarding

    Extension 'mysql_' is deprecated
    In this case we provide back-compatability

    $version = function_exists( 'mysqli_get_server_info' ) ? mysqli_get_server_info( $dbh ) : mysql_get_server_info( $dbh );

    It means if your server supports mysqli_ functions it will use theirs.

    Regarding WPMU Dev Facebook plugin - unfortunately, we will no longer be supporting these plugins. More information here.

    Regarding Rebranded Meta Widget plugin - it's very old plugin. Use Ultimate Branding instead this one. These errors were fixed there.

    Best regards,
    Ivan.