PHP7 Compatibility with select plugins

The WP Engine PHP7 compatibility checker tool has marked your plugins Smart Crawl and WPMU Dashboard have errors listed if we were to update to PHP7. We're in the process of preparing our site to upgrade to PHP7, and love your plugins, can you confirm compatibility or ETA on PHP7 compatibility for Smart Crawl and WPMU Dashboard?

  • Tyler Postle

    Hey Comit,

    I'm using both plugins on a sandbox site that is using PHP 7 and haven't run into any issues with them; however, thanks for bringing this up - I'm unsure if the developers are already aware so I've reported the incompatibility errors just in-case. I'll post back here once I receive confirmation on whether they are safe to use or not in a PHP 7 environment.

    Any further questions in the meantime just let us know

    Cheers,
    Tyler

  • Tyler Postle

    Hey Comit,

    So good news, all errors have already been fixed for the next release of both plugins

    In addition, those errors shouldn't stop you from upgrading either.

    For the WPMU DEV Dashboard mysql_ is only called on the system info page in the support tab, which just gives you info on your server/WordPress install.

    For SmartCrawl, they may generate some wanrings in your logs while in debug mode but even though the constructors have been deprecated they will still work until PHP8, and the update will be out long before that

    Hope that helps!

    Cheers,
    Tyler