Php7 Upgrading error

Hi..

I do not know whether you can help me with this issue or not.. let me explain the issue i am having with my wp site Bansurimusic.com

I am using https with php7, but when i upgraded to php7 some errors were coming in fronted and backend. The siteground support gentlemen disabled the opcache in php7 and those errors were corrected. Actually I want to have opcache feature in php7 enabled without any errors.

Is this issue can be fixed? please let me know.

Thank you.

  • Patrick

    Hi again Venugopal

    It looks like you have WP_DEBUG_DISPLAY set to "true" in your wp-config.php file. You shouldn't need to have that unless you are actively building and debugging your site. It's preferable to keep debug display set to false on a live site so your users don't freak out unnecessarily.

    Check your wp-config.php and ensure your debug settings are as follows:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', false);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', false);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);

    As for the Fatal error: Allowed memory size error, that means that the memory you have allocated to WordPress is insufficient for the tasks you're giving it. I would recommend increasing that to a full gigabyte so you never see that nonsense again. Add the following to your wp-config.php file:

    define( 'WP_MEMORY_LIMIT', '1024M' );
    define( 'WP_MAX_MEMORY_LIMIT', '1024M' );

    Please be sure that any defines or constants you add to your wp-config.php file are added before the line that says /* That's all, stop editing! Happy blogging. */. Anything added after that can break your site.