Please, enter correct Facebook API settings

is anyone else having this problem? i've tried to create a new application but on version 2.0 i always get that error. it was working nicely with the previous version.
Doesn't matter what App ID/API key, and Application Secret i put there none of them works.

  • Timothy Bowers

    Hey boogermann.

    I was looking at an issue on another members site a couple of days ago. That was a conflict with NextGen.

    So if you are sure those credentials are correct, then you might want to go through checking for conflicts. Deactivate all other plugins, revert to the default Twenty Eleven theme and test again. If it goes away then it definitely was a conflict. You can then re-activate each one, one at a time until you find the conflicts.

    Take care.

  • Marcus

    @Phil, yes. after i press "save changes to this section" you can see a loader like facebook one really quick then the error appears.

    @Timothy. I've try that. disabled all plugins and revert back to the twenty eleven, but no success. the error on the backend still happens.

    The screenshot is attached. I'm running this wordpress on a nginx, php-fpm machine. i don't know if that has any influence, but the version 1.6.2.1 was running ok.

  • Marcus

    Timothy,

    I've tried without success, had used large_client_header_buffers 4 8k; and large_client_header_buffers 8 8k; and none of them worked.
    here is my nginx.conf and the domain.conf just in case.
    i've been looking at the logs since i updated but nothing shows up, which make hard to find the problem since last version was working ok.
    Thanks for the help.

    "nginx.conf"
    user nginx nginx;
    worker_processes 2;

    pid /var/run/nginx.pid;

    events {
    worker_connections 1024;
    }

    http {
    include /etc/nginx/mime.types;
    default_type application/octet-stream;
    log_format main '$remote_addr - $remote_user [$time_local] '
    '"$request" $status $body_bytes_sent "$http_referer" '
    '"$http_user_agent" "$http_x_forwarded_for"';
    access_log /var/log/nginx_access.log main;
    error_log /var/log/nginx_error.log debug;
    sendfile on;
    tcp_nopush on;
    tcp_nodelay off;
    server_tokens off;
    keepalive_timeout 15;
    large_client_header_buffers 4 8k;
    include /etc/nginx/conf.d/*.conf;
    }

    domain.conf
    upstream backend {
    server unix:disappointed:tmp/php5-fpm.sock;
    }
    server {
    server_name domain.com http://www.domain.com;
    root /var/www/domain.com/html;
    access_log /var/www/domain.com/logs/access.log;
    error_log /var/www/domain.com/logs/error.log;
    index index.php;
    location = /robots.txt { access_log off; log_not_found off; }
    location = /favicon.ico { access_log off; log_not_found off; }
    location ~ /\. { access_log off; log_not_found off; deny all; }
    location ~ ~$ { access_log off; log_not_found off; deny all; }
    location ~* \.(engine|inc|conf|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(\..*|Entries.*|Repository|Root|Tag|Template)$|\.php_ { deny all; }
    location / {
    try_files $uri $uri/ /index.php;
    }
    location ~ \.php$ {
    fastcgi_split_path_info ^(.+\.php)(.*)$;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
    fastcgi_intercept_errors on;
    fastcgi_pass backend;
    }
    location ~* \.(js|css|png|jpg|jpeg|gif|ico)$ {
    expires max;
    add_header Pragma public;
    add_header Cache-Control "public, must-revalidate, proxy-revalidate";
    log_not_found off;
    }
    }

  • Timothy Bowers

    Nothing jumps out at me there..... Perhaps try setting it ridiculously high just to test, and then pop it back.

    In the Ultimate Facebook admin there, is there anything in the "error log" section?

    If not, then would it be possible for me to have access to your sites network admin and your facebook. You could assign me as a developer/admin to the app so I can checkout settings.

    If the previous version worked, I wonder if reverting back it will still work? Or if it would just coincidental and something else somehow changes as you upgraded.....

    Let me know. :slight_smile:

    Take care.

  • Timothy Bowers

    Hey there.

    I just sent over a friends request.

    I'll be honest, I don't use facebook much so sending me messages there might go unseen :wink:

    You will also need to mail over your site network admin details, I might also need FTP as well please just in case.

    You can send those details via our contact form, just be sure to mark it to my attention to ensure I don't miss it. :slight_smile:

    https://premium.wpmudev.org/contact/

    Take care.
    Tim.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.