Please, enter correct Facebook API settings

is anyone else having this problem? i've tried to create a new application but on version 2.0 i always get that error. it was working nicely with the previous version.
Doesn't matter what App ID/API key, and Application Secret i put there none of them works.