PLEASE take over... we capitulate entirely as things don't work

Valued Support-Team,

regards registration and signing up for membership2PRO. There are so many incorrect settings and we do not know how to solve... even after studying guide. In short we are overwhelmed and unable to get it right.

Most important, the registration form is incomplete; also at no time any data fields e.g. for entering payment details are shown.

Please let us urge you take over and correct the settings we have done to get finally membership2pro working for us to.

Attached some screenshot to show a few major troubles.

Meanwhile we switch our site in construction mode again, to avoid undesired user registration.

Please request direct server access.
BIB, BIG thanks for understanding.
Cheers
Prinz

  • Patrick
    • Support Monkey

    Hi there @Prinz

    I hope you're well today despite all these issues!

    I'm terribly sorry to hear about all the trouble you're having with getting Membership2 set up properly on your site, and we hate to see you hurting. We would certainly love to help you get this up & running so you can start making some money with your memberships. :slight_smile:

    Would you please first grant support access to the site under the Support tab in your WPMU DEV Dashboard? We could thenj login to start checking out your setup and maybe spot a few things that can be adjusted.

    Also, it may be prudent to send us admin login credentials as well as FTP login credentials in case we need to do some deeper troubleshooting. Please use our secure contact form here:
    https://premium.wpmudev.org/contact/

    Select "I have a different question" from the options, and use this as the subject line to ensure it gets routed to my inbox:
    Attn: Patrick

    ...and please include all of the following information:

    Admin username: ____________
    Admin password: ____________
    Site URL: ___________________

    FTP Host URL: ______________
    FTP username: ______________
    FTP password: ______________

    Link to this thread: https://premium.wpmudev.org/forums/topic/please-take-over-we-capitulate-entirely-as-things-dont-work

  • Klaus
    • The Crimson Coder

    Hello Patrick,
    it seems you are busy getting membership2pro for us running as we received a view emails from STRIPE e.g.

    Problem with your Stripe webhook (http://bestofthebestonly.com) for Bestofthebestonly
    Fri 04/09/2015 01:26
    It looks like we've had a bit of trouble delivering webhooks to your live webhook handler running at http://bestofthebestonly.com. Since 2015-09-01 06:43:09 +0000, at least 72 of the times we've attempted to deliver a webhook have failed, and none have succeeded. Looking at the most recent failure, we received an HTTP status code of 302 from your webhook URL. It looks like your webhook URL returned ....
    In order to reduce load on our systems, we'll stop sending webhooks to this URL if we continue to see failures after September 10. However, we'd appreciate it if you could either fix the issue or delete the webhook URL before then.
    ...

    Yours,
    The Stripe Team

  • Klaus
    • The Crimson Coder

    Hello Patrick,

    we are really concerned and worry about the m2pro issue and not knowing are you going to fix our installation now?
    Sorry to ask so direct but as you know in previous times you have let us always in the bad situation not to support at all... just wasting valuable time. However, we do not hope that this will be this time the same case again. Therefore PLEASE, PLEASE update us what's the status of this support request.

    Thank you
    Prinz

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Prinz

    Hope you are doing good today :slight_smile:

    I saw you mentioned in your email that you are using protection on your VPS that is not allowing the support access.

    The 302 HTTP response is clearly the being caused by your VPS suppress issue. Or if you are using any password protection, .htaccess protection then requests sent by Stripe or PayPal would not be successful.

    Please disable password protection and test it again from stripe dashboard. This should fix the issue.

    For other issues, I could find your email containing the login credentials but username and password seems to be invalid or changed.

    The best way is if you could enable support staff access, because this is also interfering with stripe http notifications.

    Thanks for your patience :slight_smile:

    Cheers, Sajid

  • Klaus
    • The Crimson Coder

    Hello Sajid,
    thanks for taking over. Frankly we do instantly hope to get finally m2pro working entirely. Now, regards the steps you mentioned... sorry we checked those things to the best of our knowledge. Result this does not cause the issue we are confronted with.

    It already starts with the registration fields itself (a hassle since the beginning in June, when there installation failed). Please help to fix that. What we mean by that, that there is in the standard registration (register a visitor and obviously a bp field) one field which should be the Name field but, there is a second one to and it is impossible to delete. Currently we renamed that specific field as MUST field to demonstrate what we are talking about.

    Next, when a visitor register, they get automatically into the Member Directory with many rights for our site, e.g. activation of access and register a group or becoming friends with members and so on. We checked all settings for those hassle and disabled such credentials too but anyhow that does not work.

    Next: View Member list within m2Pro. First of all, all seven administrator we granted are there - two are displayed as SuperAdmin all other as Administrator only. We are wondering, what is the different between those both which occurs in m2PRO only. For all seven people for we granted right from the beginning SUPERAdmin rights and there is NO site administrator at all nominated, no on main domain nor on any sub domain. Also, the system counts in total 8 administrator but there are 7 only.

    Next: The signup form for Visitor registration seems to work (exceptionally that issues described above). Now, when a visitor signs up a membership, all existing signup fields don't show up at all.
    Next: Redirection before and after register for a membership does not work properly either...
    Next: We are entirely unable to deal with the stripe webhook and urge you dearly, please do for us this implementation. We refer also to the STRIPE email we got (see above on this post) and do not know how to solve that case too.

    There might be other issues too which we don't realize yet as we are already unable getting the first step - registering of visitors - right.

    Therefore please be so kind setup for us the entire process properly and let our help call not unheard. We do really need your professional expertise.

    Support access is granted. Also did we forward the direct server access credentials and needed db access confidentially to you via 'have a different question'. Please check your emails.

    Many thanks in advance.
    Kind regards
    Prinz

  • Tyler Postle
    • CGO

    Hey Prinz,

    I just emailed you in regards to this; however, I didn't notice you had support access open - so I was able to sign in :slight_smile: no need to send those credentials I mentioned in my reply to you.

    I'm looking into the issue here and just want to confirm that it's okay if I take your site out of construction mode temporarily to do some testing? I'll make sure to re-activate construction mode after. I mentioned this in the email too, sorry for repeating myself :smiley:

    After investing through the dashboard, I noticed you are using Membership 2's Profile Fields add-on instead of BuddyPress' registration. Would it be okay to use BuddyPress' registration instead? I think that would be easier to integrate in this case since you already use BP :slight_smile: I can help set that up.

    Look forward to hearing back!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Prinz,

    I've finished investigating this and I found a number of issues, most of which I've fixed now.

    1. The BP and M2 registration pages were all mixed up. Make sure that the BP and M2 pages are all different. If any of them are using the same page then it will cause a conflict.

    I created 2 pages, the M2 Memberships page and the BuddyPress registration page. You can change these pages if you like but just make sure that you add the same shortcode on to the new ones that I have on there now.

    You can see if you signup through this link that everything works now: http://www.bestofthebestonly.com/botbos-membership-realm/register-botbo-membership/

    I did a successful purchase/sign up with the username: tyepo3 - you should be able to see it on the backend now.

    2. The mailchimp add-on was causing this fatal error:

    PHP Fatal error: Class 'M2_Mailchimp' not found in /wp-content/plugins/membership/app/addon/mailchimp/class-ms-addon-mailchimp.php on line 293

    This one I'm still looking into as I'm not able to replicate the error myself. Do you mind if I do a full plugin/theme conflict check? That means I'll temporarily swap to the default 2015 theme and also temporarily deactivate all other plugins. I'll reactivate the plugins and the theme afterwards :slight_smile:

    3. Your theme has multiple styling issues. It was hiding all the page content. I got the content to show again by disabling the following options:

    Trades Child Settings > Header: General Settings > "Sticky main header" and "sticky post-header".

    It still looks like there are some other styling issues going on with the theme, they may be theme setting related though - do you have support from the theme author? I would really recommend asking them about the styling issues as they will be familiar with the theme and be able to provide solutions faster :slight_smile:

    4. The stripe issue was likely because the registration process never completed properly because of the mailchimp fatal error. Since I've disabled the mailchimp add-on, stripe functions properly.

    The remaining issue:

    - The mailchimp add-on fatal error. I see this as the remaining issue now I'm sure you are wanting this to function properly so you can re-enable it correct? Once I do the plugin/theme conflict checking as I mentioned above then we should be able to get this sorted out as well. So just let me know if it's okay for me to do that tonight.

    If there are other issues you are seeing then let me know.

    Talk to you soon!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Prinz,

    Okay, I think I got this all sorted out for you.

    1. Mailchimp integration issue. Since you are using the same list for all of the mailchimp add-on options and you already have our Mailchimp sync plugin active, you don't actually need the M2 mailchimp add-on. New users should already be getting invitations to join your list on sign up :slight_smile:

    2. Your theme styling issue was due to your "BuddyPress Social Icons" plugin. It was messing up all the styling of your theme. I looked at the settings for that plugin and it didn't look like you were actually using any of the options. So I have just disabled it for you.

    You asked this through email:

    Then when finish please let me know to which URL address we have to direct the web hook key on the STRIPE Dashboard and where (within which file on our server) we have to change eventually that web hook code as well.

    The one you are directing it too now is working :slight_smile: I just tested it. So you can just leave that as-is.

    Hope this helps! Give the sign up a test run starting from here: http://www.bestofthebestonly.com/botbos-membership-realm/register-botbo-membership/

    If you still see any issues just let me know.

    Cheers,
    Tyler

  • Klaus
    • The Crimson Coder

    Hello Tyler,

    now... hmm.. how to express best and adequately our massive gratitude for all your efforts you put into our application? Well, 'Givepoints' is a matter of course... but far to less for the support you gave.

    At this space Only Words are possible: With sincere heartily BIG, BIG THANK YOU!!!
    Sincerely also on behalf of our entire Team
    Prinz

    NS: Please help us to understand a view things (in plain English) as listed below...

  • Klaus
    • The Crimson Coder

    Okay, here all the explanation we need to understand m2PRO better and to avoid to do any harm to that installation:

    1. MailChimps integration issue. ... understood, done.
    2. "BuddyPress Social Icons" plugin. ... understood, already deleted entirely.

    3. STRIPE.... settings: Do we understand right if we only change/update those key settings as shown in screenshoot? Nothing else necessary? How about WPMU MarketPress plugin (and other plugins e.g. Events): do we have to set those key there as well or not as they could eventually interfere m2PRO?

    4. We viewed both pages BotBO Memberships and BotBO Registration you created new: Now...
    - do both side have the same shortcode??? See sreenshoots
    - m2PRO Settings: should the second button not be set to BotBO Registration?
    - m2PRO Option: ADD MEMBER. Do we have all the time after a Visitor decided to join as member add that visitor profile? If so... but, actually when a visitor registers and the visitor registers a membership, both registration are then listed already in USER. In short, we do not understand this option. Please explain...

    Also: Clicking on that option it shows a nice simple USER (we call them GUEST Visitor) registration form. How can we use respective display that form for new visitor registration?

    Actually the USER registration takes the fields provided from BP. Okay, we could delete there the additional fields we added... but, why has m2PRO such a form implemented?

  • Klaus
    • The Crimson Coder

    5. At the moment bot registration forms for Visitor and Member are the same. While Visitor should be encouraged to signup with a view entries only, for new Membership registration we need all those added fields (see User Profile fields - extended Basic Profiles). How do we achieve that? Also, we are wondering do we have to enter on that extended Basic Profile also the bank account details (needed for STRIPE) or when and where does a new member enter such needed information?

    6. The current registration form has those PW fields, were the person can choose any simple PW. But, according to security reason, we wish to a) first use those WordPress Password Policy Manager... Can we activate that plugin and how to change registration form? We assume this policy is supported by m2PRO. However, that wp password plugin generates pw's and we are wondering on which 'Automated Email Response' Template and where to edit/send out accordingly?

    7. Now, we when we updated 'Automated Email Response' Templates we recognized, there is now one for passwords. Also, the 'Send Copy to Administrator' is by default in our case set to hr-direct@... We wish to update the default value to another email address, were can we do that? By this occasion we wish to setup that 'new default value' in general for all domains, plugins etc. Is that possible and if so, where? We checked our SuperAdmin Network setting and changed it there... but it takes place partially at some occasion only but not generally.

    8. When a visitor is signing up, the person is added and listed automatically in Member List. Well, we can change that manually for each visitor via USER update... but we are wondering were to block visitor only (not member). There are many reason not automatically add them to the member list, as this would deliver lots of dummy avatars on sidebar widget (as it is most unlikely that a visitor uploads an image).

    9. Finally: We are going to use WPMU Dev Automessage Plugin... please, dear Tyler, let us know, if we can add the following sentence (right beneath our signature) which is... from our experience absolutely true and a highly desire to do so:

    I'm very pleased to welcome you to the BotBO Community and look forward to working with you!

    Yours
    Beatris Prinz
    BotBO Community

    *BIG, BIG THANK YOU you to our tireless, excellent and highly qualified Support Team at WPMU Dev (Melbourne, VIC, Australia) finally to get the BotBO Community Webportal up and running. We appreciate, honor and value everything the Support Crew did for our endeavor at crazy times and over all the time. Yes, we are filled with huge gratitude.

    We are looking forward hearing from you soon,
    HUGE, MASSIVE, BIG Thanks

    Prinz

  • Tyler Postle
    • CGO

    Hey Prinz,

    Happy to help! :slight_smile: I'll address each of your questions here individually. If you need further clarification on any of them just let me know.

    3. STRIPE.... settings: Do we understand right if we only change/update those key settings as shown in screenshoot? Nothing else necessary? How about WPMU MarketPress plugin (and other plugins e.g. Events): do we have to set those key there as well or not as they could eventually interfere m2PRO?

    Right, so when you want to go "live" just add in your live stripe API key's and swap the dropdown over to the "live mode". Using Stripe in other plugins won't cause any conflict(ie. MarketPress) even if you're using the exact same account/api keys :slight_smile:

    4. We viewed both pages BotBO Memberships and BotBO Registration you created new: Now...
    - do both side have the same shortcode??? See sreenshoots
    - m2PRO Settings: should the second button not be set to BotBO Registration?
    - m2PRO Option: ADD MEMBER. Do we have all the time after a Visitor decided to join as member add that visitor profile? If so... but, actually when a visitor registers and the visitor registers a membership, both registration are then listed already in USER. In short, we do not understand this option. Please explain...

    -Yes, both those new pages need to have the same shortcode.
    -The BP and M2 registration pages need to be different pages in order for the BP registration add-on to work correctly. So you should leave them as-is
    -ADD MEMBER is only if you want to manually add a user to your site and manually assign a membership to them. If your user signs up through your frontend site registration then "add member" isn't necessary for them.

    Also: Clicking on that option it shows a nice simple USER (we call them GUEST Visitor) registration form. How can we use respective display that form for new visitor registration?

    You can use this shortcode in a page to display a more simple sign up form:

    [ms-membership-register-user]

    Actually the USER registration takes the fields provided from BP. Okay, we could delete there the additional fields we added... but, why has m2PRO such a form implemented?

    Yes, because we are using the BP registration add-on. I was under the impression you were wanting to integrate it with the BP sign up so you could use the BP fields?

    5. At the moment bot registration forms for Visitor and Member are the same. While Visitor should be encouraged to signup with a view entries only, for new Membership registration we need all those added fields (see User Profile fields - extended Basic Profiles). How do we achieve that? Also, we are wondering do we have to enter on that extended Basic Profile also the bank account details (needed for STRIPE) or when and where does a new member enter such needed information?

    Perhaps you would like to use the regular Membership registration form instead? and then use BP registration for visitors? Right now we are integrating the BP registration form into the Membership 2 signup. Another option would be to use the shortcode I provided above to embed a more simple visitor sign up form on another page.

    As for Stripe information, they won't add that until after they confirm the membership they want :slight_smile: then a little stripe payment popup will appear for them to fill out.

    6. The current registration form has those PW fields, were the person can choose any simple PW. But, according to security reason, we wish to a) first use those WordPress Password Policy Manager... Can we activate that plugin and how to change registration form? We assume this policy is supported by m2PRO. However, that wp password plugin generates pw's and we are wondering on which 'Automated Email Response' Template and where to edit/send out accordingly?

    This is not currently integrated because the Membership registration process requires their password in order to log them in automatically and continue the Membership registration seamlessly. If the password needed to be auto-generated then it wouldn't be able to auto-log them in correctly. So you would need for them to sign up first then manually go to the Memberships area after logging in.

    7. Now, we when we updated 'Automated Email Response' Templates we recognized, there is now one for passwords. Also, the 'Send Copy to Administrator' is by default in our case set to hr-direct@... We wish to update the default value to another email address, were can we do that? By this occasion we wish to setup that 'new default value' in general for all domains, plugins etc. Is that possible and if so, where? We checked our SuperAdmin Network setting and changed it there... but it takes place partially at some occasion only but not generally.

    I'm not seeing one for passwords, where are you seeing that one?

    As for the "send to administrator" you can just add a user to your site as an "administrator" role with the email you want to send too and then you will be able to select it :slight_smile: as for forcing an admin email across the whole network, that's not an option yet so you would need to do manually but I'll mention that feature to the developer, I think it would be a good one.

    8. When a visitor is signing up, the person is added and listed automatically in Member List. Well, we can change that manually for each visitor via USER update... but we are wondering were to block visitor only (not member). There are many reason not automatically add them to the member list, as this would deliver lots of dummy avatars on sidebar widget (as it is most unlikely that a visitor uploads an image).

    We don't currently have an option for that yet. There is the bar of Memberships above the Members list so you can select the Membership you want to see users for and that will filter out all others including visitors. As for the widget in the sidebar, that looks like the BuddyPress members widget? If so, then moving the "visitor" users out of Members won't make a difference because they will still be users within your WP installation.

    9. Finally: We are going to use WPMU Dev Automessage Plugin... please, dear Tyler, let us know, if we can add the following sentence (right beneath our signature) which is... from our experience absolutely true and a highly desire to do so:

    Yes of course you can! Thanks very much for the shoutout :slight_smile:

    10. Instead %username%

    enter %firstname% in automated email
    response, does this work with m2PRO?

    You will want to use this one for the first name: %user-first-name%

    Here is a list of all the email variables:

    %ms-name%

    %ms-remaining-days%

    %ms-remaining-trial-days%

    %ms-expiry-date%

    %ms-invoice%

    %user-display-name%

    %user-first-name%

    %user-last-name%

    %username%

    %ms-account-page-url%

    %blog-name%

    %blog-url%

    Hope that helps Prinz! Look forward to hearing back.

    Cheers,
    Tyler

  • Klaus
    • The Crimson Coder

    Hello Tyler,

    huge - huge - massive Thank you!

    Those explanation helped us a lot.

    We close this request for good and mark it as saved (nevertheless two minor navigation are to solve but we open for that a new support request).

    Prinz

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.