Plug in fails to install - package is not available

I’m getting an error every time i’m trying to install a plug in.. is there an activation time frame i need to wait till i can install a plugin?