Plugin Activation Error on New Website Install

I have been trying to install the WPMU DEV Dashboard Plugin on a website but after activating the plugin and entering the login credentials to WPMU I am directed to a white screen with an error message. Tried the install on a different site and get the same message.

{“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”:404}}

Any thoughts on how to resolve the error?

  • Jude
    • DEV MAN

    Howdy JonA

    Welcome to the community !

    Do you have CloudFlare active on the site ? If yes, can you disable it and try again please ?

    If not can you try resetting your API key in your wpmudev.org profile page, and see whether you are still having issues with login.

    https://premium.wpmudev.org/hub/account/

    Finally if still stuck, can you try enabling the debug log file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WPMUDEV_API_DEBUG', true );
    define( 'WPMUDEV_API_DEBUG_ALL', true );

    These lines should be added above the “/*That’s all, stop editing line…” in your wp-config.php file. After you add them, please try logging in again and then access your server via FTP, download the “debug.log” file (it should be located inside the “/wp-content” folder) and paste the last few lines here

    Cheers

    Jude

  • JonA
    • WPMU DEV Initiate

    Turned off CloudFlare on their site and tried again – issue still present

    Deactivated the CloudFlare Plugin on my website – issue resolved.

    Also tried installing an additional plugin and that works now as well.

    Thanks for the quick reply!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.